Pirate4x4.Com : 4x4 and Off-Road Forum - View Single Post - Longevity Plasma Cutters, Welders, Multi-Purpose Units, and Generators
View Single Post
Old 04-04-2012, 03:55 PM   #1269 (permalink)
longevity-inc.com
Rock God
 
longevity-inc.com's Avatar
 
Join Date: Jul 2008
Member # 116114
Location: Hayward, CA
Posts: 1,566
Quote:
Originally Posted by toten View Post
A friend of mine has an LS160P that he got a few years ago that isn't working in AC. Using 6013 or 7024 (what we had around) I can lay great beads in DCEP, but switch to AC and it just won't hold an arc. He had been hoping to do some aluminum TIG with it, but obviously without AC he can't do that - and he was having the same problem (can't hold an arc) when trying AC TIG.

Any suggestions for how to get it to work right? If not, what's the best contact?
Hi Toten,

There are several things you may be happening here. One, your settings, two the frequency gap on the machine may need to be adjusted. However, it seems that if you are able to DC TIG, then you have to fine tune your AC settings.

You can give our welder a call. Please send over an email to help@longevitywelding.com with your contact info. Send this original message as well as our welders do not browse the forums. However, they will call you back once customer service issues a trouble ticket.
__________________
For Faster Service Email or Call for Price Quotes: daniel@longevity-inc.com , john.bazan@longevity-inc.com, or nicolas.rivera@longevity-inc.com

Toll Free:877-566-4462
Website: www.longevity-inc.com

YouTube Welding Channel: www.youtube.com/longevitywelding
Join our Free Welding Forum at: www.FreeWeldingForum.com
LONGEVITY Sponsored Racing: www.longevity-racing.com
longevity-inc.com is offline   Reply With Quote