Fuel pump relay randomly clicks off & engine dies - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Chevy
Notices

Reply
 
Share Thread Tools Display Modes
Old 10-03-2008, 02:21 PM   #1 (permalink)
Rock God
 
rockcrawln's Avatar
 
Join Date: May 2004
Member # 30586
Location: Redwood Valley, CA
Posts: 1,326
Fuel pump relay randomly clicks off & engine dies

I have a '91 350 TBI that I put in a jeep years ago. The engine has been nothing but awesome. Recently it started to die randomly so I stated doing some investigations and found out that the fuel pump relay is clicking off. Anyone know what would cause the computer to turn off the fuel pump relay? I have replaced the relay and pump for good measure (pump was pretty old). I was also told it could be a bad ignition control module so I replaced that before I found the fuel pump relay issue. So, where should I start? What will make the computer freak out and try to shutdown the engine?

Thanks
__________________
For the best deal on 8 lug disc brakes click here--> www.lugnut4x4.com
rockcrawln is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 03:03 PM   #2 (permalink)
Registered User
 
Join Date: Feb 2007
Member # 86878
Location: South of Heaven
Posts: 2,572
Are you sure the relay is opening before the engine stalls?

If it is, the PCM may be losing tach signal causing it to open the relay and kill the engine.
Igntion module was a good guess. But a broken wire or bad contact can cause loss of tach signal also.

Are there any DTCs?
Do you have the MIL hooked up?
__________________
-Vinny
[COLOR="Black"]-[/COLOR]from Elizabeth
[COLOR="Black"]Nobody cares about your rigs specs...
[/COLOR][COLOR="Lime"]"Me too" short Crew build[/COLOR]

[url]http://www.pirate4x4.com/forum/showthread.php?t=994394[/url]

^^ Parting Out ^^
Odin K30 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 10-03-2008, 03:50 PM   #3 (permalink)
Rock God
 
rockcrawln's Avatar
 
Join Date: May 2004
Member # 30586
Location: Redwood Valley, CA
Posts: 1,326
Sorry, but what is a DTC or MIL?

It's kinds hard to tell what's happening first. If it's not the relay where else do you think I should start. It's kind of annoying having a nice jeep that won't run. Thanks for any advise you can give.
__________________
For the best deal on 8 lug disc brakes click here--> www.lugnut4x4.com
rockcrawln is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 04:58 PM   #4 (permalink)
Registered User
 
FrankenToy's Avatar
 
Join Date: Oct 2004
Member # 36822
Location: Toyotaville, just west o' Denver
Posts: 2,174
DTC's are codes, is it throwin' any?

MIL is your "Check Engine Light".

It could be that your oil pressure sensor is on the fritz intermittently, too.

Check for codes first (which is what everyone will tell you).
__________________
Seems the fools are in charge now and they demand a high tariff... Me
FrankenToy is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 05:57 PM   #5 (permalink)
Rock God
 
rockcrawln's Avatar
 
Join Date: May 2004
Member # 30586
Location: Redwood Valley, CA
Posts: 1,326
no check engine light and no codes. The oil pressure switch has been unhooked for months. Will the comp kill the engine if it doesn't sense pressure?
__________________
For the best deal on 8 lug disc brakes click here--> www.lugnut4x4.com
rockcrawln is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 06:23 PM   #6 (permalink)
Registered User
 
Join Date: May 2008
Member # 114479
Location: Western Ma.
Posts: 20
Quote:
Originally Posted by rockcrawln View Post
no check engine light and no codes. The oil pressure switch has been unhooked for months. Will the comp kill the engine if it doesn't sense pressure?

Yes. The relay has a timer in it to energize the pump for 2 seconds when you turn the key, then waits for oil pressure before re-energizing. If you lose oil pressure while running it should kill the pump for safety.
__________________
Second place is a body bag- Carlos Hathcock
Warpig58 is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 06:46 PM   #7 (permalink)
Rock God
 
rockcrawln's Avatar
 
Join Date: May 2004
Member # 30586
Location: Redwood Valley, CA
Posts: 1,326
What gets me is the engine will run between 2 and 15 min before dieing. That's why I never really suspected the oil pressure switch as being an issue.
__________________
For the best deal on 8 lug disc brakes click here--> www.lugnut4x4.com
rockcrawln is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 06:56 PM   #8 (permalink)
Registered User
 
Join Date: Apr 2002
Member # 11016
Location: maine
Posts: 191
The engine should run with the fuel pump relay out of the system. The relay is used for initial key on prime,and after you have OP all current is flowing thru the oil pressure switch. Your problem is not the relay, it is with OP switch or associated wiring.
__________________
66 Bronco 2006 HD2500 Duramax
ALEX Bronco is offline   Reply With Quote Quick reply to this message
Old 10-03-2008, 08:12 PM   #9 (permalink)
Registered User
 
Join Date: Sep 2006
Member # 80052
Location: St. James, MN
Posts: 2,015
Send a message via MSN to the_experience3006 Send a message via Yahoo to the_experience3006
I have to agree with the above post in that the oil pressure switch will run the truck after it hits a threashold (4psi?), but both failing is seriously questionable. Is your ECM intermittently turning off and on? I know it will be difficult to check and in fact a good scan tool might be the best way, but I think that it's powering down. Intermittent stuff like that can often be fixed by just tightening some connections that work loose over 17 years. To test the oil pump switch start the truck and get it running and pull the relay. If the engine continues to run then the issue isn't the OP switch. You could also check continuity, but pulling the relay gives you a good test. If it continues to run the problem is elsewhere like a bad tach signal or a bad connection causing the ECM to stop pulsing the injectors.
__________________
[QUOTE=abig84;9192789]i swear id be gay if it wasn't for all the gay sex that's involved[/QUOTE]

[QUOTE=TexasBlake;10305687]She's not that hot. I was just looking for a quick lay and she all wanted to like go on dates and shit.
[/QUOTE]
the_experience3006 is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.