steering problems need help - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Chevy
Notices

Reply
 
Share Thread Tools Display Modes
Old 10-27-2009, 06:53 PM   #1 (permalink)
Registered User
 
Join Date: Mar 2009
Member # 130894
Location: st louis missouri
Posts: 3
steering problems need help

just bought a 1980 chevy 454 4speed 205 10'' or 12'' lift all spring. has steering problems i dont know if its the s link or 3 inch riser on knuckle... have pics but cant figure out how to post so if you have an idea please e mail at qiksilverado@hotmail.com for pics

Last edited by 1baddually; 10-27-2009 at 07:15 PM.
1baddually is offline   Reply With Quote Quick reply to this message
Old 10-27-2009, 07:09 PM   #2 (permalink)
Registered User
 
Join Date: Feb 2008
Member # 107883
Location: Garden Grove, CA
Posts: 805
Your problem is most likely the 12" lift.
PS:For solutions you should probably tell us what the problems are....
__________________
[URL=http://www.pirate4x4.com/forum/showthread.php?t=871614]Plasma Table Build / Torchmate 2x2[/URL]
Chevy Build with 5TonRocks......Coming Soon.....:flipoff2:
JeepsRcool is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 10-27-2009, 07:14 PM   #3 (permalink)
Registered User
 
Join Date: Mar 2009
Member # 130894
Location: st louis missouri
Posts: 3
my bad.. the wheel turns lock to lock. the tires only turn about half that. once the pitman arm goes so far it starts putting pressure on the leaf springs and gear box as if the s link is binding or something.
1baddually is offline   Reply With Quote Quick reply to this message
Old 10-28-2009, 01:41 AM   #4 (permalink)
Registered User
 
Join Date: Nov 2008
Member # 123438
Location: Canaidia
Posts: 145
the problem is not the 12 inch lift. . . leave it to a jeep to cry about your truck height.

theres enough force in your steering box to put force on everything if you turn it past full lock. sounds like the problem is in your steering linkage or youve got the wrong box on there.

if youve got the block style steering its inferior and you should try and get yourself a good crossover highsteer kit
Hellbilly Delux is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.