Newer Dodge Truck guys - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Dodge
Notices

Reply
 
Share Thread Tools Display Modes
Old 11-27-2001, 03:46 PM   #1 (permalink)
Registered User
 
Chazzworth's Avatar
 
Join Date: Feb 2001
Member # 3340
Location: US of A.
Posts: 321
Send a message via AIM to Chazzworth
Newer Dodge Truck guys

Hey what are you getting for mpg? My Wifes pos 99 with the 360 gets almost 11mpg and that is with a lot of freeway. Thanks, Anyone have specific web sites on the lemon law?
Thanks
__________________
"I once had wealth, power, and the love of a beautiful woman, now I only have two things, my friends, and...uh... my Thermos."
Chazzworth is offline   Reply With Quote Quick reply to this message
Old 11-27-2001, 07:44 PM   #2 (permalink)
Registered User
 
jasonmt's Avatar
 
Join Date: Feb 2001
Member # 3236
Location: Alberta, Canada
Posts: 3,779
My 99' 1 Ton 4X4 with 4000# of welding equipment gets 14-15 mpg ( cummins, 6 Speed, A few mods to the engine ) and that is going 70-75 mph on the highway. My previous welding truck ( 1 Ton Chev., 454, 5 speed also got about 11 mpg. ) I would be flippin a nut at the dealer if a unloaded, light duty truck is only getting 11 mpg. Is the truck mechanically sound??
__________________
[QUOTE=Roxywheels]The trolls always out themselves :laughing: :roxy:[/QUOTE]
jasonmt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 11-28-2001, 06:56 AM   #3 (permalink)
Registered User
 
Join Date: Jan 2001
Member # 2743
Posts: 141
MPG

My wife drives a 97 4x4 ext. cab sport (360, AT) and gets 14-15 mpg. It just turned over 100,000 miles.
bwright is offline   Reply With Quote Quick reply to this message
Old 11-28-2001, 07:47 AM   #4 (permalink)
Registered User
 
Join Date: May 2001
Member # 4878
Location: Bremerton, WA
Posts: 6,226
Send a message via ICQ to Travis Waldher Send a message via MSN to Travis Waldher Send a message via Yahoo to Travis Waldher
my 96 1500 4x4, 360, auto.. gets aroun 11-12mpg in town (heavy right foot) and cruises at 16.5mpg in O.D., almost regardless of what I am towing behind it.
Travis Waldher is offline   Reply With Quote Quick reply to this message
Old 11-28-2001, 09:19 AM   #5 (permalink)
Registered User
 
Chazzworth's Avatar
 
Join Date: Feb 2001
Member # 3340
Location: US of A.
Posts: 321
Send a message via AIM to Chazzworth
Quote:
Originally posted by jasonmt
getting 11 mpg. Is the truck mechanically sound??
Hell No It is a p.o.s. I am looking into getting it bought back thru the Lemon Laws. I hate the truck. It has its third tranny in it, you can pull the ignition key out and start the truck without it sometimes, Pressing the o.d. off button only seems to turn the dash light on does not change the shift habits, and low m.p.g. with no power, and I still have not fixed the No speedo under 30mph, the ABS light and Brake light is on. All those problems for a 99 with almost 50kmiles on it. Sounds like a lemon to me. I just want to get it bought back before I put more money into it. I hate it. THanks for the help guys. Please keep the MPG info coming.
__________________
"I once had wealth, power, and the love of a beautiful woman, now I only have two things, my friends, and...uh... my Thermos."
Chazzworth is offline   Reply With Quote Quick reply to this message
Old 11-28-2001, 10:03 AM   #6 (permalink)
Registered User
 
Patman's Avatar
 
Join Date: Feb 2000
Member # 236
Location: Hollister Ca.
Posts: 196
Chazz do a search there is plenty of info about the lemon law on the net.

Basically it has to have been in the shop for the same problem 3 times in 12 months. That's a little over simplyfied, but basically that's it.

by the sounds of your mileage, your SOL on that. Good luck
__________________
You mean your not supposed to work 18 hours a day, 7 days a week???
Patman is offline   Reply With Quote Quick reply to this message
Old 11-28-2001, 11:43 AM   #7 (permalink)
Registered User
 
Join Date: May 2001
Member # 4878
Location: Bremerton, WA
Posts: 6,226
Send a message via ICQ to Travis Waldher Send a message via MSN to Travis Waldher Send a message via Yahoo to Travis Waldher
hey chazz, Is your computer posting any codes? maybe clogged exhaust or air filter. the catalytic converters on the damn things are notorious for going out early in life. (federal warranty to 80k on them)

Maybe she is going doen the freeway in 2nd gear?

(seriously, my shifter linkage slipped a little, I need to adjust it back but right now, drive is between D and N and second is closer to drive.)
Travis Waldher is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:25 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.