plz help gas gusler!!! - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Ford
Notices

Reply
 
Share Thread Tools Display Modes
Old 12-21-2005, 06:09 AM   #1 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
plz help gas gusler!!!

87 ranger 2.9 xlt ext cab auto 4x4

why is it when im going down the hwy in over drive i got to put my foot threw the firewall just to keep going 75mph. i get about 200 miles to a tank.

please help what can i do.
epicsling@yahoo.com
epicsling is offline   Reply With Quote
Old 12-21-2005, 06:56 AM   #2 (permalink)
Registered User
 
Join Date: Aug 2005
Member # 51216
Location: Tuscaloosa,Alabama
Posts: 13
Do you have over sized tires? Is the truck stock? Is it running right other than the gas problem?
Bamataco1 is offline   Reply With Quote
Sponsored Links
Old 12-21-2005, 07:07 AM   #3 (permalink)
Registered User
 
Join Date: Sep 2000
Member # 1713
Location: Sacto & Nevada City
Posts: 587
Assuming it ran better, Cat?
__________________
69 EB ARB's, 37's, 5.0, ZF, 148:1 bla, bla, bla.....
Broncrick is offline   Reply With Quote
Old 12-21-2005, 11:06 AM   #4 (permalink)
Registered User
 
Join Date: Nov 2004
Member # 39126
Location: New Berlin, WI
Posts: 218
Drive slower
BrokeCuzWheelin is offline   Reply With Quote
Old 12-21-2005, 04:14 PM   #5 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
yes the truck is totally stock. normal tires. truck runs fine minus the stated problem. it also runs weak in overdrive when stressed. i was thinkin maybe the low pressure pump might have gone out. the high press is loud, so loud im not sure if i can hear the low press. i do feel a slight vibration on the outlet hose from low press pump but that could be caused by the high press pump sucking out the fuel. i cut a access panel in the bed to test the low press pump with the key on but i was told that if i use a test light on it i will blow my ecu. i know it sounds stupid but its not a chance i want to take.
epicsling is offline   Reply With Quote
Old 12-21-2005, 07:50 PM   #6 (permalink)
winch operator
 
bobbywalter's Avatar
 
Join Date: Dec 2002
Member # 15473
Location: prudenville mi
Posts: 795
Send a message via AIM to bobbywalter
you wont blow the ecu, its not connected to the pumps, it only grounds a relay to run the pumps.


sounds like the low pressure may still work and the high is laying down too. if it has the canister filter still it could be plugged as well. i got one here i am looking at this weekend with the same problem. it has good f/p at idle, and its a brand new engine..figure the injectors are bad or the oversize cam is causing problems if it is not bad pump volume.
__________________
if only




88 ranger ext cab pos hackjob powered by a 6.5 diesel clattering against a 4l80 thats punishing a f208 that is turning ford 60's rolling on 33-44 in tires depending on the mission at hand

how ya like me now??
bobbywalter is offline   Reply With Quote
Old 12-23-2005, 05:49 AM   #7 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
how can i test the pumps. both pumps and filter are about 5mo old
epicsling is offline   Reply With Quote
Old 12-23-2005, 06:00 AM   #8 (permalink)
Registered User
 
Lars915's Avatar
 
Join Date: Jul 2002
Member # 12876
Location: Loveland, CO
Posts: 873
An 87 Ranger was engineered to run 55mph. At 75 you're way out of the efficiency curve. Slow down.
Lars915 is offline   Reply With Quote
Old 12-23-2005, 06:16 AM   #9 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
R U Serious!!!!!!!!! I Hear What You Are Saying. But I Know That This Truck Can Run Better. My 88 Nissian P/u 4cyl 4 Spd Had More Power, Better Preformance, And Better Mpg. And I Could Run It Down The Highway Up To 80mph.
epicsling is offline   Reply With Quote
Old 12-23-2005, 06:18 AM   #10 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
my check engine light has not come on. if i have a sensor out it should be lit, correct?
epicsling is offline   Reply With Quote
Old 12-23-2005, 06:43 AM   #11 (permalink)
winch operator
 
bobbywalter's Avatar
 
Join Date: Dec 2002
Member # 15473
Location: prudenville mi
Posts: 795
Send a message via AIM to bobbywalter
it will strobe intermittently unless something is dead. when its one or two things out of range it wont leave it on. it is is on, your in fmem and it will run like nutless ass like your having.

does it code still?
__________________
if only




88 ranger ext cab pos hackjob powered by a 6.5 diesel clattering against a 4l80 thats punishing a f208 that is turning ford 60's rolling on 33-44 in tires depending on the mission at hand

how ya like me now??
bobbywalter is offline   Reply With Quote
Old 12-23-2005, 07:07 AM   #12 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
"does it code still?"

what do you mean. on my yota i can self test. can i do the same w/ my ranger.
epicsling is offline   Reply With Quote
Old 12-23-2005, 08:27 AM   #13 (permalink)
Rock God
 
Join Date: Mar 2003
Member # 18283
Location: Florida
Posts: 1,321
yes you can pull codes yourself.

you need to find the diagnostic connector in the engine compartment you short two pins & then count the # of times the CEL flashes you'll need a manual for what the codes mean.

Check fuel pressure.
Bad FPR will give you very bad economy.

mileage you need to change gears. they were geared to run 55. I pulled 20-22 out of my 2.9 5 speed w/ 3.55 gears on 235/75/15 tires. Economy is going to be given my keeping the engine under 3k. I can just about guarantee that you're running far over that right now.

guessing that you've prob got a bad O2 Sensor.
__________________
There are no rules. You have to think!
demonranger is online now   Reply With Quote
Old 12-23-2005, 09:33 AM   #14 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
thanks i will try the test. and take a look at the o2. but i have no ideal what kind of gears are in this thing. or where to look.
epicsling is offline   Reply With Quote
Old 01-02-2006, 07:23 AM   #15 (permalink)
Registered User
 
epicsling's Avatar
 
Join Date: May 2005
Member # 47530
Location: Texas
Posts: 71
Send a message via Yahoo to epicsling
any other ideals?
epicsling is offline   Reply With Quote
Old 01-03-2006, 06:28 AM   #16 (permalink)
Rock God
 
Join Date: Mar 2003
Member # 18283
Location: Florida
Posts: 1,321
gears are on a tag attached to the rear diff or you can cross reference the rear axle code from the info tag on the driver's door.

how many gallons are you putting in when you fill up your tank? IIRC 87 was the swap year for the fuel tank size and you may have the small tank 12 or 15 gallons I think.
__________________
There are no rules. You have to think!
demonranger is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.