Low boost pressure? - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Ford
Notices

Reply
 
Share Thread Tools Display Modes
Old 09-13-2007, 05:23 PM   #1 (permalink)
Rock God
 
Join Date: Oct 2003
Member # 23545
Location: Osburn Idaho
Posts: 1,911
Low boost pressure?

Im running a early 94 ford tubo diesel so it is pre powerstoke but only by a little. It is a 1ton which i have heard makes a difference in 94 compared to the 3/4 ton. It has a aftermarket intercooler and stock airbox. Ok my problem is that its only pushing about 6lbs of boost. I have heard so many numbers of what is right. All i know is that sure sounds low to me. The truck runs great and has around 245,000 miles on it. Can anybody help me or tell me what numbers i should be running? Thanks for the help.
crewchief is offline   Reply With Quote Quick reply to this message
Old 09-13-2007, 06:31 PM   #2 (permalink)
Rock God
 
82F100SWB's Avatar
 
Join Date: Nov 2002
Member # 15263
Location: Dryden, Canada
Posts: 2,166
Send a message via ICQ to 82F100SWB Send a message via AIM to 82F100SWB Send a message via MSN to 82F100SWB Send a message via Yahoo to 82F100SWB
6 doesn't sound all that far out of line, most say that bone stock the factory turbo trucks run 8-10 at most. With the intercooler, most people speak of a 1-2 psi loss across the cooler, so, sounds like you're in the ballpark. You can adjust the waste gate and maybe add more fuel, keep your EGT's at safe levels, and the boost in the "safe" 10-12 psi range.
Personally, I'd disable the gate completley and give it lots of fuel, my truck runs 15 psi peak at current temps(more as it gets colder) and I have a slow spooling non gated turbo, and no intercooler... At -25, I'm making 18 psi, and we see -40 here...
__________________
96 F350 XL CC PSD/5 speed 4x4... Family hauler in the making
92 W250 LE, CTD/5 speed 4x4, tow pig/DD/snow pushin pig
86 F250... 460/T19/1345/D60/welded 10.25, 44 Boggers, reg cab, some junk... Build
82F100SWB is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 09-13-2007, 10:53 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2006
Member # 75808
Location: washington state
Posts: 13
I also have a 94 turbo diesel also known as IDI (indirect injected). My truck has 180k on her with all stock components other than a k&n drop in filter and no muffler, just straight pipe. My turbo is stock but the waste gate is permanantly closed. I can hit 15psi when it is cooler or when i am loaded but i don't push it past there. I'd love to find a tech that can work on this thing and maybe give it some more power. How much did the intercooler help power performance. Hope that this info helps out
__________________
need motivation......... will pay!
beatupbronco is online now   Reply With Quote Quick reply to this message
Old 09-14-2007, 08:15 AM   #4 (permalink)
Rock God
 
Join Date: Oct 2003
Member # 23545
Location: Osburn Idaho
Posts: 1,911
i think the intercooler really helped and seemed to really keep the egts down. Whats the best way to disable the wastegate? Im also thinking of getting a new set of injectors. Anybody have a good place to get them. We have a good place here that rebuilds our injectors so i might sent them over there. Its a great truck i just wish it had a bit more power. How do ya increase the fuel on those pumps?
crewchief is offline   Reply With Quote Quick reply to this message
Old 09-14-2007, 08:19 AM   #5 (permalink)
Registered User
 
mjlogan88's Avatar
 
Join Date: Oct 2003
Member # 23553
Location: Riverside, CA
Posts: 1,637
Quote:
Originally Posted by crewchief View Post
How do ya increase the fuel on those pumps?
http://www.members.shaw.ca/k2pilot/I...%20article.htm
mjlogan88 is offline   Reply With Quote Quick reply to this message
Old 09-14-2007, 12:12 PM   #6 (permalink)
Rock God
 
Join Date: Oct 2003
Member # 23545
Location: Osburn Idaho
Posts: 1,911
thanks mjlogan! all i need now it to mess with the waste gate.
crewchief is offline   Reply With Quote Quick reply to this message
Old 09-15-2007, 08:24 AM   #7 (permalink)
Registered User
 
Join Date: Jul 2006
Member # 75808
Location: washington state
Posts: 13
The shaft of my waste gate broke where it goes to the turbo linkage so mine is just completely closed, You just need to make a linkage that wont allow it to open. I know this isn't the right way to do things, but like i said, it broke and needed a quick fix.
__________________
need motivation......... will pay!
beatupbronco is online now   Reply With Quote Quick reply to this message
Old 01-14-2008, 12:46 PM   #8 (permalink)
Rock God
 
Join Date: Oct 2003
Member # 23545
Location: Osburn Idaho
Posts: 1,911
i know this is bringing up an old post but i have a question regarding this. For some reason my truck when its not fully warmed up runs great with alot of power put the warmer it gets the more power loss i have. Does this make sence to anyone? Also what is the best way to disable the waste gate. I think mine is bad and dumping my boost right out the exhaust. Thanks Garrett
crewchief is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.