H3T Questions - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Hummer
Notices

Reply
 
Share Thread Tools Display Modes
Old 11-16-2011, 08:44 AM   #1 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
H3T Questions

I would like to start a thread that has all the small questions about the H3T.
What fits, what works, and mostly quick questions. There is another thread on here about H3 Buttons that has turned into ask all thread of the sorts.

Smalls questions, fast responses. Try to keep the chit chat low.

Dumb questions are allowed.

Question 1.

Will H3 stock rims work on H3T?

I am looking to buy another set of wheels for off road use only. I have run into issues with 4runner and tacomas in the past and I don't want to purchase a set off craigs list and have caliper issues or the sorts.
__________________
1970 FJ40
dcastell is offline   Reply With Quote
Old 11-16-2011, 10:46 AM   #2 (permalink)
Registered User
 
Join Date: May 2006
Member # 72609
Location: Orlando
Posts: 144
To be honest I have never actually checked but to my knowledge they are interchangeable.
HummerNewbie is offline   Reply With Quote
Sponsored Links
Old 11-16-2011, 11:22 AM   #3 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
Well, I am buying some on Friday. I will post up my results.

Next question:

Bebe stated that I could call any GM dealership and give them the code for the roof rack and the hard bed cover key cylinders. I called Go Chevrolet in Denver and the parts kid said that they could only do the ignition and doors. Not the accessories.

What is the next step? I don't really want to pay for locksmith
__________________
1970 FJ40
dcastell is offline   Reply With Quote
Old 11-16-2011, 01:33 PM   #4 (permalink)
Registered User
 
Join Date: Dec 2010
Member # 176853
Location: Florida
Posts: 9
Wheels are the same. Like Bebe said there should be numbers on the locks, any locksmith should be able to make a key from that. On the bed cover if you can't find a number on the lock look at the inside of the cover for the serial # & contact Diamondback. http://www.diamondbackcovers.com/
JGBB04 is offline   Reply With Quote
Old 11-17-2011, 10:00 AM   #5 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
JB4975F8,

Thanks for all the help and info. I have sourced my keys and will be waiting for them shortly.

Thanks,
Dcastell
__________________
1970 FJ40
dcastell is offline   Reply With Quote
Old 11-21-2011, 03:40 PM   #6 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
Strange issue this morning. I went to start the truck and nothing. Full power to everything, but no turn or a click. Pushed the truck a bit, put the gear selector in park again, but no luck.

I just disconnected the battery for a minute and then reconnected. The truck started just fine. No check engine lights or the sorts. Truck ran just fine.

What happen here?

Thanks,
__________________
1970 FJ40
dcastell is offline   Reply With Quote
Old 11-27-2011, 01:22 PM   #7 (permalink)
Registered User
 
Join Date: Jul 2006
Member # 75601
Location: Las vegas
Posts: 120
Never had that issue in my H3, but my wifes 07 tahoe with the 5.3 did that exact same thing. disconnected the battery and hooked it back up started right up. That was 3 years ago. Told the dealer and they had no idea and couldnt pull a code.
silvrzuki77 is offline   Reply With Quote
Old 11-30-2011, 08:26 PM   #8 (permalink)
Registered User
 
Join Date: Jan 2009
Member # 128331
Location: Glendale Arizona
Posts: 549
Does your truck have an anti theft device or a remote engine start? When you turned your key did the instrument panel light up like it normally does?
Overdosed is offline   Reply With Quote
Old 12-01-2011, 05:44 AM   #9 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
Quote:
Originally Posted by Overdosed View Post
Does your truck have an anti theft device or a remote engine start? When you turned your key did the instrument panel light up like it normally does?
I believe my truck does have the anti theft device and the remote engine start, but I have not figured it out yet. The instrument panel did light up. The entire car was powered up, except it would not start. It has not done it since.
__________________
1970 FJ40

Last edited by dcastell; 12-01-2011 at 05:44 AM.
dcastell is offline   Reply With Quote
Old 02-15-2012, 02:29 PM   #10 (permalink)
Registered User
 
dcastell's Avatar
 
Join Date: Feb 2008
Member # 109545
Location: Denver
Posts: 702
Happened again. Went out this morning and the truck would not start. Lights were fine, dash was fine, but no start. I disconnect the two smaller line at the battery and it started. Reconnected and I have had no issues all day. Weird shit.
__________________
1970 FJ40
dcastell is offline   Reply With Quote
Old 02-15-2012, 05:15 PM   #11 (permalink)
flamethrower
 
Bebe's Avatar
 
Join Date: Jul 2006
Member # 75270
Location: Auburn, CA
Posts: 9,036
Send a message via Yahoo to Bebe
Your battery could just be getting old?

Take it to Napa or Pep boys and have them do a load test on it.
__________________
What's all the Hub-bub about Blue Stars??? Click Here
Haulin the Groceries AND Haulin the MAIL
Bebe is offline   Reply With Quote
Old 02-16-2012, 12:07 AM   #12 (permalink)
Registered User
 
Join Date: Nov 2010
Member # 175478
Posts: 199
I had this problem...bad battery terminals. The stock ones are not that great. Swapped em out and no problems since...I would wiggle the battery terminal when they were bad and that let the electrical kick on

Sent from my DROIDX using Tapatalk
__________________
06 Hummer H3- 3 link, dana 44, coil springs, spring over rear locked up soon to have 37-38s.
06 H3 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.