seems like a common issue, but can't find answer... dr.window & power locks failing? - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Hummer
Notices

Reply
 
Share Thread Tools Display Modes
Old 03-25-2012, 11:31 AM   #1 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 196213
Location: Dumont, CO
Posts: 73
seems like a common issue, but can't find answer... dr.window & power locks failing?

Well... Sled season is winding down PITIFULLY early here in CO, so I'm faced with actually fixing a problem we've had for a while now on the H3 (07 base fyi).

The driver window, and power lock switches are continuously failing... they work on occasion, but mostly dead now. This completely locks me out of the back door... which REALLY sucks. Now that I'm wheeling again (went to the snow on N empire today, had fun, but not too far) the window is budding me as well.

I've tried pulling battery, pulling fuse 68 & a few others, disconnected door wires a few times... next step I'm assuming is to buy a new switch assy. I wanted to see what you guys thought about that, and see if there's a better way to do it, some other option I haven't thought about, or a simple way to test to see where the issue lies.

Any ideas?

Right now I've got 68 out completely... I DO NOT need the retarded auto lock system kicking in, then not being able to open my back door, so I eliminated the power lock system completely... only option I had. If someone knows how to turn off the asinine aut lock BS, PLEASE let me know, it's the thing I've HATED about this thing since day one. Risk of carjacking is minimal here in the mountains... I'll be ok without it
__________________
07 H3, 35's, swaybar free.
High in the rockies... the only place where summer is actually bearable.

Last edited by backcountryislife; 03-25-2012 at 11:35 AM.
backcountryislife is offline   Reply With Quote
Old 03-26-2012, 11:01 AM   #2 (permalink)
Registered User
 
Join Date: May 2006
Member # 72609
Location: Orlando
Posts: 144
Does the lock work fine via the remote? You can always unlock the back door with the remote if needed. I have not looked at the wiring but couldn't you just as a test wire up another switch, from another door or completely different vehicle to test the window? If it works then you know it's the switch, if not time to move further down the line. Same would work for the lock switch. I have never looked for it but I believe there are instructions on how to disable the auto lock in the manual.
HummerNewbie is offline   Reply With Quote
Sponsored Links
Old 03-26-2012, 02:55 PM   #3 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 196213
Location: Dumont, CO
Posts: 73
There is no option for disabling the auto lock... there's option 1, obnoxious, option 2, retardedly annoying, and option 3, fu**ing moronic... that's what the owner's manual gives you Sorry... the idea of my car locking me in REALLY pisses me off when I can't shut it off. It was the FIRST thing I got rid of in every other vehicle I've owned with auto locks... and this is the first vehicle I've ever seen that doesn't allow you to get rid of that option.


The remote fails when the auto locks fail, and the driver window goes at the exact same time. I'm not that great with wiring, so don't really want to yank the switches & try hard wiring them... but guess I could try that.


Btw... the wheeling is still a TAD snowy here at 10k+

__________________
07 H3, 35's, swaybar free.
High in the rockies... the only place where summer is actually bearable.

Last edited by backcountryislife; 03-26-2012 at 03:13 PM.
backcountryislife is offline   Reply With Quote
Old 03-26-2012, 03:14 PM   #4 (permalink)
flamethrower
 
Bebe's Avatar
 
Join Date: Jul 2006
Member # 75270
Location: Auburn, CA
Posts: 9,028
Send a message via Yahoo to Bebe
Have you tested your battery? Some times batteries which are at the end of their life can cause "gremlins".
__________________
What's all the Hub-bub about Blue Stars??? Click Here
Haulin the Groceries AND Haulin the MAIL
Bebe is offline   Reply With Quote
Old 03-31-2012, 06:38 PM   #5 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 196213
Location: Dumont, CO
Posts: 73
haven't tried testing it... bringing it in on tuesday.
__________________
07 H3, 35's, swaybar free.
High in the rockies... the only place where summer is actually bearable.
backcountryislife is offline   Reply With Quote
Old 04-06-2012, 07:42 AM   #6 (permalink)
Registered User
 
linemen339's Avatar
 
Join Date: Mar 2010
Member # 157195
Location: Ma
Posts: 357
The 06 and 07 H3 had trouble with there BCM. They fixed the trouble in 08. My wifes 06 has the same trouble as you are having. I have done some looking into it. The best fix is to get a new one. Getting one out of a junkyard won't work unless you find one that has the same options as your H3
__________________
W.O.D. Rock Bouncer, 540 BBC, TH350, Atlas II on Rockwells
linemen339 is offline   Reply With Quote
Old 05-14-2012, 12:37 PM   #7 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 196213
Location: Dumont, CO
Posts: 73
FYI, I had the ECU flashed & it hasn't been a problem since. Still same battery, no other changes.

Cost me a few bucks, didn't fix what I was hoping it was going to fix... but it DID fix this, so it was worth it, having a window is a cool feature in the summer!
__________________
07 H3, 35's, swaybar free.
High in the rockies... the only place where summer is actually bearable.
backcountryislife is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:58 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.