argh mystery sounds... - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Isuzu
Notices

Reply
 
Share Thread Tools Display Modes
Old 02-05-2004, 09:24 PM   #1 (permalink)
Registered User
 
Join Date: Dec 2002
Member # 15939
Location: McChord AFB, WA
Posts: 449
Unhappy argh mystery sounds...

Well i have encountered a wonderfull sound. I was out four wheeling today whith my brother. I got perty wild had one rear tire up in the air perty good (i have pics and video if anyone whants host them ). But on the way home i crawled through a nice deep mud hole, watter was coming into the cab through the door seels and such. But i had my luv parked at my bros apt. and its realy cold out now (frost all over it). When i whent to pull out of the parking lot i heard a pop followed by a constant low volume squeel. Could this just be frozen watter somewhere. My transmision skid plate was drug through the snow perty good once. Could it be that some of that snow froze to the drive shaft? Just looking for possible things to look at tomarow in the shop...
__________________
1999 Stock poser TJ, DD
1973 Wagoneer, mall crawler project...

Last edited by mepr; 02-05-2004 at 09:31 PM.
mepr is offline   Reply With Quote
Old 02-06-2004, 05:44 AM   #2 (permalink)
Typical White Guy
 
Join Date: Feb 2002
Member # 9769
Location: Indy
Posts: 1,775
Re: argh mystery sounds...

Quote:
Originally posted by mepr
. Could this just be frozen watter somewhere.
Probably. If the shop is heated, just park the truck there for a few hours to let everything melt off and see what that does for you. Pretty much anything that moves while you're driving (brake rotors, driveshafts) could have some ice on it that's dragging against something else while you drive. If the shop isn't real warm and you want to speed things up, start taking a hair dryer to stuff. I'd start at the brakes and wheels.
________
Marijuana vaporizers

Last edited by Indyguy; 04-26-2011 at 07:51 PM.
Indyguy is offline   Reply With Quote
Sponsored Links
Old 02-06-2004, 08:27 AM   #3 (permalink)
Registered User
 
Join Date: May 2000
Member # 1005
Location: Almost Idaho
Posts: 172
Did you set the parking brake? If so, it is probably the brakes draging.

If not, Sean is right, it could be a multitude of things from brakes to even something like getting water in the diff and having it freeze up.

Michael
mlclark is offline   Reply With Quote
Old 02-06-2004, 09:01 AM   #4 (permalink)
Uzi
Wheeler
 
Join Date: Oct 2003
Member # 23703
Location: Lincoln NE
Posts: 213
Do you have auto-lock hubs?
Mine made popping and grinding noises after encouters with water. They suck anyways but that might be one more thing to look at if can't figure out that noise.
__________________
1987 Isuzu Trooper II
SAS and Motor swap
D44-12 bolt 36 TSL's

Quote:
Originally Posted by Haole View Post
Woof, woof. Fag.
Uzi is offline   Reply With Quote
Old 02-06-2004, 11:53 AM   #5 (permalink)
Registered User
 
Join Date: Dec 2002
Member # 15939
Location: McChord AFB, WA
Posts: 449
no my hubs are manuals. I guess ill just get the stove in the shop going and let my luv thaw out today. Thanks
__________________
1999 Stock poser TJ, DD
1973 Wagoneer, mall crawler project...
mepr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.