Stock XJ Fuel Pump failed...again - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Cherokee
Notices

Reply
 
Share Thread Tools Display Modes
Old 07-08-2007, 06:04 PM   #1 (permalink)
Registered User
 
Cyrus's Avatar
 
Join Date: May 2005
Member # 48037
Location: Zeeland Michigan
Posts: 113
Stock XJ Fuel Pump failed...again

The fuel pump in my XJ has failed twice in the last 4 months, seems to be due to over heating when fuel levels are low (below half tank) during steep hill climbs the pump noise level increases drasticly, then the engine stumbles then quits, once the rig is level, she fires back up. I realize the pump and pick up are being uncovered, causing the engine stall and pump failures.

Besides a custom fuel cell and inline race style pump, what have you done to eliminate this problem? Foam the tank, incline adjusting fuel pick up ( cahinsaw style ), what have you done

Throw out your ideas, fixes and if they worked or not


Thanks for your help
__________________
i drive junk.
Cyrus is offline   Reply With Quote
Old 07-08-2007, 06:09 PM   #2 (permalink)
Registered User
 
Join Date: Nov 2006
Member # 82394
Location: Orangevale
Posts: 372
Change the filter & see what happens.

I've been through 2 pumps in the last 5000 miles.

One died in the driveway, the other one died 70 miles from home......
BerzerCO is offline   Reply With Quote
Sponsored Links
Old 07-08-2007, 06:16 PM   #3 (permalink)
Registered User
 
Cyrus's Avatar
 
Join Date: May 2005
Member # 48037
Location: Zeeland Michigan
Posts: 113
I changed the filter when the first pump failed in march, I know the pump has run dri on a couple of occasions, well more than a couple. my son stood her on end three weeks ago at the badlands in Attica. The pump went from silent during operation to noisy enough to hear, then yesterday I stood her up a few times and the pump started screaming, then quit. No pressure run up at start up. I checked power at the the pump, 13.8 volts. relay is good and fuse is good.

I know the pump failed, and I know why, I need to eliminate or at least eleviate the root cause; inlet uncovering during hill climbs.



RT
__________________
i drive junk.
Cyrus is offline   Reply With Quote
Old 07-08-2007, 10:15 PM   #4 (permalink)
Registered User
 
Join Date: Nov 2004
Member # 37792
Posts: 259
i had a problem with mine also, after trailing for a long period, i would shut the rig off and then it would not start back up. i dont know what the problem was exactly, i just cycled the pump a few times after it sat for about ten minutes and it would fire. who knows, run 'er till she blows
stevej21 is offline   Reply With Quote
Old 07-09-2007, 06:16 AM   #5 (permalink)
TJP
Registered User
 
Join Date: Oct 2001
Member # 7595
Location: Alternate Universe
Posts: 1,135
I've never had thiis problem but I also keep the tank over 1/2 full when offroad.

My suggestion = stop at a gas station and fill it up.
__________________
Great spirits have always encountered violent opposition from mediocre minds.
-Albert Einstein :flipoff2:
TJP is offline   Reply With Quote
Old 07-09-2007, 06:32 AM   #6 (permalink)
Registered User
 
Cyrus's Avatar
 
Join Date: May 2005
Member # 48037
Location: Zeeland Michigan
Posts: 113
Quote:
Originally Posted by TJP View Post
I've never had thiis problem but I also keep the tank over 1/2 full when offroad.

My suggestion = stop at a gas station and fill it up.
it was,,, 3/4 full when I left camp in the morning, read 5/8 at tiem of failure when sitting level on the ground...
__________________
i drive junk.
Cyrus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.