Full Hydro Reservoir Mounting - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Hardcore Tech
Notices

Reply
 
Share Thread Tools Display Modes
Old 10-29-2009, 03:52 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Member # 116355
Location: Tucson, AZ
Posts: 100
Full Hydro Reservoir Mounting

Where are you guys mounting your reservoirs for your full hrdro steering? Im having trouble getting the reservoir high enough to have the outlet above the pump. I have a yj with the 4.0L so the pump is on the top of the serpentine loop. I would have to drill a hole in my hood and stick it through there. please post pics of where your mounting them. Any ideas?
jasn123456 is offline   Reply With Quote Quick reply to this message
Old 10-29-2009, 03:55 PM   #2 (permalink)
Rock God
 
KyleQ's Avatar
 
Join Date: Dec 2006
Member # 83837
Location: Minnesota
Posts: 1,787
Quote:
Originally Posted by jasn123456 View Post
Where are you guys mounting your reservoirs for your full hrdro steering? Im having trouble getting the reservoir high enough to have the outlet above the pump. I have a yj with the 4.0L so the pump is on the top of the serpentine loop. I would have to drill a hole in my hood and stick it through there. please post pics of where your mounting them. Any ideas?
Early bronco is probably just as bad... I used a -10an to -10an fitting to directly mount the reservoir on the pump and built a support bracket. It sticks out of the hood, but will never starve the pump. I tried mounting it lower to fit under the hood and it killed the pump.

__________________
74' Bronco - Mustang Injected 5.8 - 105:1- Locked D60, Powr-Lok 70U - NP435 -Atlas2 3.8 - PSC Full Hydro - 5.5" lift - Cage Arms - 43" TSL SX on H1 Beadlocks
Bronco Build Thread
KyleQ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 11-05-2009, 07:10 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2008
Member # 117078
Location: Nebraska
Posts: 22
I mounted mine on the radiator support, right where the factory one was at. It's a tight fit, but just clears the hood.

I made a bracket to hold the reservoir mount and adjusted it up as close as I could.

Trick I did for the suction line, was to use the factory suction hose(has a pre-formed 90* bend). After cutting it to the right length, it fit perfectly.


Couple of pics....





Edit: obviously the zip straps are temporary...

Last edited by Autodocgi; 11-05-2009 at 08:15 PM.
Autodocgi is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:02 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.