Quick- Loc is broke???? - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share Thread Tools Display Modes
Old 02-16-2006, 03:31 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41730
Posts: 10
Quick- Loc is broke????

My brother just had the following installed on his 82 CJ7:
Quick loc rear, 1 piece yukon axles, new ring and pinion f&r, and new bearings and seals.

He said that after he got it back he took it for a test drive and in the corners it would ratchet and then it popped and it doesnt ratchet anymore. He says it feels like its fully locked now. What could be the problem? Thanks for the help guys.
jnelson300ex is offline   Reply With Quote
Old 02-17-2006, 01:14 AM   #2 (permalink)
Registered User
 
Join Date: Oct 2005
Member # 54940
Posts: 217
I think I'd say welcome to the world of automatic lockers. He does know if your on the gas it will stay engaged, automatic lockers only disengage when there is no load on them.
__________________
95 YJ with a few mods
OhioYJ is offline   Reply With Quote
Sponsored Links
Old 02-17-2006, 12:19 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41730
Posts: 10
Yeah im pretty sure he knows this. We are wondering if the guy put it in wrong, it took him almost a month to put all the stuff in. It should still be ratcheting though right, evn without any gas through corners?
jnelson300ex is offline   Reply With Quote
Old 02-17-2006, 09:49 PM   #4 (permalink)
Registered User
 
Join Date: Oct 2005
Member # 54940
Posts: 217
A month is quite a while. It be pretty hard to mess up a Quick Loc install, theres not much to jam up in it honestly. Your supposed to check tolerances before you do the final install, but even if he had it to tight, it would still disengage, probably with a loud bang. I know I don't always hear my locker ratcheting, somedays its louder than others. You could pop the cover and make sure nothing looks out of place.
__________________
95 YJ with a few mods
OhioYJ is offline   Reply With Quote
Old 02-18-2006, 07:46 AM   #5 (permalink)
Registered User
 
Join Date: Aug 2005
Member # 51634
Posts: 163
It probably did not have oil on all the surfaces yet causing the loud and violent disengagement.
savageracing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.