led light help - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share Thread Tools Display Modes
Old 06-12-2008, 07:10 PM   #1 (permalink)
Registered User
 
Join Date: Apr 2008
Member # 113110
Posts: 17
led light help

I have an 05 rubicon with poison spyder rear led lights. when i used the turn signals they used to blink real fast but they would work. i recently put on tube fenders and genright led front turn signals they stopped working and make this terrible errrrrr noise what do i need to do?
05unlimicon is offline   Reply With Quote Quick reply to this message
Old 06-12-2008, 08:22 PM   #2 (permalink)
Registered User
 
Join Date: Dec 2006
Member # 83985
Location: Central Texas
Posts: 81
Gotta replace the turn signal fuse with one designed for LEDs.

Ordered mine from Mark Lochridge @ Gold Coast Distributing. Click Here




Works great.
__________________
Insert Signature Here: ____________________

Last edited by rketr; 06-12-2008 at 08:23 PM.
rketr is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 06-12-2008, 09:57 PM   #3 (permalink)
Registered User
 
Join Date: Sep 2006
Member # 78734
Location: Edmonton, AB
Posts: 84
Or you could try this first and save some cash.

http://www.stu-offroad.com/electrical/led1/led-4.htm

Worst case scenario: y ou wreck it and have to buy one anyway.
__________________
'03 TJ
http://myjeeptj.com <- write-ups, trip reports, gallery, etc.
Raskull is offline   Reply With Quote Quick reply to this message
Old 06-12-2008, 09:59 PM   #4 (permalink)
Registered User
 
Join Date: Aug 2007
Member # 97598
Location: Southern Indiana
Posts: 47
I've never had that problem with mine and i have LED's on all four corners. They just blink fast, and i can live with that.
jbullfrog is offline   Reply With Quote Quick reply to this message
Old 10-09-2008, 12:53 PM   #5 (permalink)
Registered User
 
Join Date: Sep 2005
Member # 53746
Location: Houston, TX
Posts: 32
Flasher Mod

I tried Stu's mod when I just had the tail-lights. Worked great. Now that I have installed the front LED's, same thing. No turn signal, no flashers. I have a relay from GCD on the way, we will see what happens....
jeepn012 is offline   Reply With Quote Quick reply to this message
Old 10-09-2008, 12:56 PM   #6 (permalink)
Zeus of the Sluice
 
oldjeep's Avatar
 
Join Date: Mar 2001
Member # 3511
Location: MN
Posts: 4,969
Quote:
Originally Posted by jeepn012 View Post
I tried Stu's mod when I just had the tail-lights. Worked great. Now that I have installed the front LED's, same thing. No turn signal, no flashers. I have a relay from GCD on the way, we will see what happens....
That'll fix it. There's just not enough load on the current flasher to make it work.
__________________
Chuck P
The clowns'? Oh, yeah, the clowns. We fight them too entire armies, spilling out of Volkswagons. We do our best to fight them off, but they keep sending 'em in!
www.oldjeep.com
oldjeep is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:52 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.