95 wrangler+code 51 halp! - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share Thread Tools Display Modes
Old 08-04-2008, 04:22 PM   #1 (permalink)
Registered User
 
Join Date: Feb 2008
Member # 109515
Posts: 20
95 wrangler+code 51 halp!

So I went down to the beach for a week and was driving on the beach about 20+miles a day. Took a few "tours" which involved some water holes on the access roads and now I'm popping a code 51. Says its o2 lean. Washed out everything and rehooked all my sensors hoping I just jogged something loose but no go. Thing sputters hard and sounds a lil whiney. Most of the time its on mid acceleration or coming off a stop especially when shifting. Any ideas? Swapped out my o2 sensor with my neighbors and still the same prob. Any suggestions?


adder. When it starts up it revs to about 1200-1500rpm and when the check engine light kicks on it drops to norm revs
______________


btw its a 95 yj 2.5 4cyl with 130k
Clutchmastercory is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.