really need some help! engine busting up when hot - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share Thread Tools Display Modes
Old 04-06-2010, 12:10 PM   #1 (permalink)
Registered User
 
Join Date: Aug 2009
Member # 140549
Location: Marbury,AL
Posts: 49
really need some help! engine busting up when hot

ookay ive done my searching and i have found nothing,. so i am flame free on that issue. but i have a 91 yj with a 4.0.. one ride last year, my jeep got to operating temputure,(give or take around 180) and started busting up and back fireing around 3000 rpms,with no power once so ever.but i got back to camo! got home and hooked the scan tool up, and got a coolant tempture sensor short,.. so relpaced the temp sensor.. everything was fine, until i went to gray rock orv, for spring fling and it started doing it again,.. so i have replaced everything you can think of from alternators to ecus. fuel pressure regulator, MAP, CPS,distuributor, coil. i mean everything. and it only does it when it is hot. i recently hooked the scan tool to it to see if it had any codes,.. and it only has a A/C circut relay code. could this be causing it to cut up when warm. i tried to clear the code but it will not let me,.. this is bothering me.
__________________
suthern rock bouncer buggy under construction.
"Hammer down, what the worst that could happen?"
fultorn is offline   Reply With Quote
Old 04-06-2010, 10:17 PM   #2 (permalink)
Registered User
 
Join Date: Aug 2008
Member # 117838
Location: Rancho Cucamonga ,CA
Posts: 161
Sounds to me maybe its mechanical. Make sure your rocker arms are adjusted right. Valves might be staying open once it get up to operating tempeture. Shouldnt do that with a hydralic cam though unless its adjusted wrong.Egr might be sticking open also .

Last edited by Caterpiller; 04-06-2010 at 10:18 PM.
Caterpiller is offline   Reply With Quote
Sponsored Links
Old 04-07-2010, 12:39 PM   #3 (permalink)
Registered User
 
Join Date: Oct 2007
Member # 101618
Location: Jackson,TN
Posts: 317
Mine did the same thing !!! I cked the fuel pressure and i had 23psi so i replaced the entire fuel pump module and its back to 52psi and it does not do it anymore... YJ fuel pressure may differ from my TJ
__________________
I got a JEEP
[url]www.twistedjeeps.net[/url]

Last edited by 4130jeeptj; 04-07-2010 at 12:40 PM.
4130jeeptj is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:45 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.