no fuel/no spark - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share Thread Tools Display Modes
Old 05-27-2010, 03:54 PM   #1 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
no fuel/no spark

i have checked everything i can find, all fuses and relays are good, ignition switch is good fuel pump works well, i have no power running to my fuel pump and no spark. i've been going through everything for 2 days now and cant find my problem.
jeepbonehead is offline   Reply With Quote
Old 05-27-2010, 05:32 PM   #2 (permalink)
Wheeler
 
PumpkinCrusher's Avatar
 
Join Date: Oct 2006
Member # 81449
Location: Sagamore Hills OH
Posts: 319
Need more details? Howell kit, OEM ?
PumpkinCrusher is offline   Reply With Quote
Sponsored Links
Old 05-27-2010, 07:03 PM   #3 (permalink)
Registered User
 
Join Date: Nov 2008
Member # 123988
Location: Koontz Lake, IN
Posts: 21
check engine light come on with the key in run position?
Wolfghost is offline   Reply With Quote
Old 05-28-2010, 12:37 AM   #4 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
Quote:
Originally Posted by PumpkinCrusher View Post
Need more details? Howell kit, OEM ?
wiring is all oem, fuel pump is an inline pump from summit.

Quote:
Originally Posted by Wolfghost View Post
check engine light come on with the key in run position?
not the last time i tried

Last edited by jeepbonehead; 05-28-2010 at 12:39 AM.
jeepbonehead is offline   Reply With Quote
Old 05-28-2010, 03:16 AM   #5 (permalink)
Registered User
 
Join Date: Nov 2008
Member # 123988
Location: Koontz Lake, IN
Posts: 21
check power and grounds to ecm, if it checks out replace ecm.

Last edited by Wolfghost; 05-28-2010 at 03:34 AM.
Wolfghost is offline   Reply With Quote
Old 05-28-2010, 05:12 AM   #6 (permalink)
Registered User
 
Join Date: Jan 2001
Member # 2790
Location: Stinnett Tx USA
Posts: 1,631
Quote:
Originally Posted by Wolfghost View Post
check power and grounds to ecm, if it checks out replace ecm.
this would be my guess.. I had a similar problem with a Dodge truck,no codes no CEL...
__________________
Russ
hy_desert_4wheeler
46 Dodge WC15--67 M715--85 Jeep CJ10A--06 Dodge Ram2500Quad cab Cummins--94 Suburban--06 Ridgeline-
hy_desert_4wheeler is offline   Reply With Quote
Old 05-28-2010, 11:09 AM   #7 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
ecm=computer?
jeepbonehead is offline   Reply With Quote
Old 05-28-2010, 11:42 AM   #8 (permalink)
Wheeler
 
PumpkinCrusher's Avatar
 
Join Date: Oct 2006
Member # 81449
Location: Sagamore Hills OH
Posts: 319
Yes. Should be located behind the glove box.
PumpkinCrusher is offline   Reply With Quote
Old 05-28-2010, 12:03 PM   #9 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
i thought it's in the engine bay on the drivers side fire wall
jeepbonehead is offline   Reply With Quote
Old 05-28-2010, 12:14 PM   #10 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
just checked voltage to ecm, correct me if i'm wrong, positive is pink with yellow stripe and ground is black. with those i got 12 volts. could any sensors make my fuel and spark turn off

Last edited by jeepbonehead; 05-28-2010 at 12:14 PM.
jeepbonehead is offline   Reply With Quote
Old 05-28-2010, 03:13 PM   #11 (permalink)
Registered User
 
Join Date: Nov 2008
Member # 123988
Location: Koontz Lake, IN
Posts: 21
yes cam position sensor and crank position sensor would make the ecm turn off fuel and spark BUT you would still have the check engine light, looks to me like you need an ecm.
Wolfghost is offline   Reply With Quote
Old 05-28-2010, 05:35 PM   #12 (permalink)
Trailbusters4x4 club
 
FuzzyZ's Avatar
 
Join Date: Aug 2008
Member # 117547
Location: Vacaville, CA
Posts: 1,537
Yup ECM would be the most likely cause that i can think of for the problems your haveing and not getting a CEL. All your voltage checks can be fine but if one of the boards in the ECM went bad ya got a problem there, not really a good way to check it with out swaping it or taking it in to get checked.
__________________
83 toy pickup, 02 TJ, 02 GMC 2500HD, 68 AMC AMX.
Trailbusters4x4 club Solano County
Dont blame me i voted Republican!
ECV 1004
FuzzyZ is offline   Reply With Quote
Old 05-28-2010, 09:22 PM   #13 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
if i swap in a friends is there any chance of frying his? or should i be okay?
jeepbonehead is offline   Reply With Quote
Old 05-28-2010, 11:17 PM   #14 (permalink)
Rock God
 
ONEtonXJ's Avatar
 
Join Date: Nov 2009
Member # 145633
Location: Grand Junction, Crawlorado
Posts: 1,478
what year and model is your rig??

used to have an '01 XJ... long story short....


XJ died... check engine light followed...

no fuel pressure...

replaced fuel pump...

still no fuel pressure...

check engine light revealed bad crank sensor...



so what im tryin to say here is... MYYY crank sensor.... turned off everthing...
__________________
Battlement Fabrication
"Tater2" - '91 2 door XJ. 4.0, AW4, 231/300 doubler, GM 60/70HD, 6.17s, ARB's & 4Ds
ONEtonXJ is offline   Reply With Quote
Old 05-29-2010, 03:44 AM   #15 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
i replaced the crank sensor already
jeepbonehead is offline   Reply With Quote
Old 05-29-2010, 08:16 AM   #16 (permalink)
HARD ROCK VEGAS
 
burtv's Avatar
 
Join Date: Dec 2006
Member # 83644
Posts: 580
do all other electrical components operate correctly?
burtv is offline   Reply With Quote
Old 05-29-2010, 05:04 PM   #17 (permalink)
Granite Guru
 
Join Date: Feb 2009
Member # 130080
Location: New Fairfield, CT
Posts: 751
fixed it. but after i replaced my ignition switch and my crank sensor the ecu was bad. i put a friends in that has the same year make model engine and trans and it came right to life. who know where the cheapest place is to get a new used or refirbished ecu
jeepbonehead is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:21 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.