Leaking PS box - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Land Rover
Notices

Reply
 
Share Thread Tools Display Modes
Old 08-29-2011, 02:35 PM   #1 (permalink)
Registered User
 
Join Date: May 2005
Member # 47968
Posts: 217
Leaking PS box

I have a leak in the high pressure fitting of my PS box from pump to box. When I say leak, I mean it runs out as if there is no fitting. Story...

I had the box tapped for hydro-assist. I didn't care for it, so I took it out. All I did to remove the assist was put in a new bleed screw and put a cap over the hydro fittings. It did not leak with the hydro, or without. Everything was normal. Several months later, it started to leak.

What I've tried:

New o-rings throughout.
New hoses. 2 stock, one OEM, one custom made.
New box. (never tapped for assist)
I've bled the system.
I've tightened the fitting to every imaginable load from way too tight to way too loose.
I've use thread tape and thread sealer.
I've used every imaginable combination of above every time I try a new part. So...new box, new hose, new o-ring, no tape, tight...leaks, open blead screw, close, leaks. Start over with new box, new hose, new o-ring, tape, tight...leaks. Start over with new box, new hose, new o-ring, no tape, not as tight...leaks. Start over....you get the point.

I took a known good, dry box and pump to a local company to have hoses made. They hooked me up and gave me the correct o-rings. I replaced everything. It leaks. If I open the bleed screw, it pours from the high pressure fitting and shoots from the bleed screw. When I remove the high pressure line from the box, fluid runs out of the line and the box.

Any suggestions?

Chad
bigbluelunchbox is offline   Reply With Quote
Old 08-30-2011, 03:28 AM   #2 (permalink)
Registered User
 
Join Date: Mar 2007
Member # 88052
Location: Montreal
Posts: 1,171
my guess is your fitting is bottoming before the o ring has made a seal with the tapered surface.
BigBlueToy is offline   Reply With Quote
Sponsored Links
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.