Just got back from Pismo - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > Motorcycles/ATVs
Notices

Reply
 
Share Thread Tools Display Modes
Old 11-28-2003, 08:46 AM   #1 (permalink)
Registered User
 
Join Date: Jun 2001
Member # 5472
Location: Cent Ca
Posts: 1,358
Just got back from Pismo

We were there for a week. Man I am sore! They have it opened up just past pole 8 right now. During the week it was great, not a whole lot of people. On Mon night we got some appreciated wind and it was smooth running on Tues morning. Most days were close to 70* (according to the therm in my truck) with a slight breeze. Had a blast jumping and drag racing (Damn YFZ beat me everytime, he was fast! and so did a bunch of those freakin Banshees). I put a K&N and a pipe on my bike before we left and it made quite a bit of difference. My Predator wheelies no prob in 3rd now and any little bump in 4th in the power band and the front is in the air. The mags can say what they want but the Predator is a good bike. No major injuries in our camp and only 1 broken bike (step sons LT 80, my dumb a$$ forgot to fill his oil resivor so it needs a new top end) for the trip. I need to get his bike fixed before New Years so we can go do it again. I will pots some pics as soon as we get them back.
__________________
Did you ever notice: When you put the 2 words "The" and "IRS" together it spells "Theirs?"
spoolnaround is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.