Pirate4x4.Com : 4x4 and Off-Road Forum - Reply to Topic
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Chevy > 1986 k20 rebuild
Notices

Thread: 1986 k20 rebuild Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-04-2013 09:26 AM
44boggers Hey bud, thanks. I moved the rest of the build over to the general section http://www.pirate4x4.com/forum/gener...nks-build.html

You can see the rest of it there.

Paul
12-03-2013 09:25 AM
77ford400 any updates this is pretty badass id love to see some update pics of how she sits
04-20-2013 04:06 PM
44boggers its under "leafs to links build"
04-20-2013 04:04 PM
44boggers no still going, the remainder of the build is in the general 4x4 section. Slow going right now, but I think the next month I should be close to getting it done.
04-19-2013 11:22 PM
468k5 no more build??????????
09-10-2012 05:31 AM
44boggers Got a bit more done this weekend. Made a new truss, I originally had a tube truss but it was becoming a pain to incorporate my shock mounts like i wanted to, so i went to flat stock and it came out a lot better. Finished up the shock hoops and mounted the ORI's. Tacked in the upper links on the truss and started making a template for the frame mount for my upper links. Then I had a little accident with mr flapper wheel which set me back a bit. Oops.

Anyways, next step is to get my links in but I am waiting on heretic fab to get back up and running. I think i am going to run aluminum upper links, mostly because I can get them for sure in the next couple weeks. i was thinking about running AL lowers but I dont think I will be able to fit 2.75" lowers under my drive shaft.
08-19-2012 12:45 AM
1989k35003+3 Looks sweet man I dig the tube work on the front of the frame. nice to see continued progression
08-18-2012 09:07 PM
44boggers So after months of hammering on the rig, i have lost all the doors and fenders. Shit I stopped wheeling with the hood anymore. Less crap to crush. Truck has been running really well but it was time for an upgrade. So i bought some 16" ORI's and i am now beginning to 4 link the front. Just going to run the winch up front and moved the rad. to the rear. Here are some progress pics.
02-28-2012 09:03 PM
Keystoneyota great build cant wait to see it up and going. nice i like seein the boggers but to good use
02-26-2012 08:11 PM
44boggers Not to worried about it anymore. I don't go into to much deep mud anymore.
02-26-2012 03:29 PM
urmyboyblue Nice rig. Did you ever figure out the wheelwell replacements? The reason I ask is because I have a roots type super charger I'm putting on my 76 CC bbc and I need to keep all the mud out (don't want my belt to slip). I still have to dove the front, I like the simplicity of yours. Do you plan to add any tube to the fenders? any thoughts and or pics would be great.
02-25-2012 10:57 AM
hybrid-theory
Quote:
Originally Posted by 44boggers View Post
Thank Duner. Its been a lot of work the last couple months .Just trying to get it ready for april so I can do some more local test runs before heading south to Rausch. Last year I went down there and lasted 45 minutes before my motor blew. Im not going let that happen again. Way to long of a drive from VT to go down there without your shit being built right.
This is going to be an awesome year!! Between your truck and Rob with 49's now!! Yea its going to be fun!!
02-25-2012 05:52 AM
44boggers Thank Duner. Its been a lot of work the last couple months .Just trying to get it ready for april so I can do some more local test runs before heading south to Rausch. Last year I went down there and lasted 45 minutes before my motor blew. Im not going let that happen again. Way to long of a drive from VT to go down there without your shit being built right.
02-24-2012 09:17 PM
Duner440 Great build! I am working on a '86 half ton, very similar build. You have a lot of good info in here. Keep it up.
02-24-2012 05:02 PM
44boggers Shifters
02-24-2012 04:59 PM
44boggers Few updates. Built a skid plate/crossmember for the trans and doubler. Got the th400 in and built some new mounts for the triple stick and art carr shifter. Getting pretty close to ready. Just need to install front gears, then buy some rcv's and front high angle. then time to test this old girl out.
12-03-2011 11:57 AM
44boggers not to much to update. Th400 is finally done, just waiting on the correct flexplate. Got the spring plates done, welded up a bomb and hydro mount welded back on.
11-29-2011 10:23 AM
FordX4-offroad im definitely diggin the d70 front...
hmmmmmm anyone got a dana70 rear they wanna sell?
11-28-2011 10:44 PM
44boggers Hey bud. Thanks for the info. I decided just to replace the two discs. I can get them
Up in Burlington. It only takes a minute to take the pump and input drum off. I appreciate the help though! Only thing left is to set up the gears, Install tranny and buy axle shafts. Can't wait for Rausch in the spring. What's the departure date?
11-28-2011 06:22 PM
koolk10 talked to a tranny guy today he said as long as the disc is flat you should be ok,if its not it'll stick and burn up.he has never seen one strip out the teeth before.but for the price of a disc he would replace especially for what we do..he can get you individual disc if its any help.
11-24-2011 06:58 AM
44boggers Well after assemblying my th400, i realized i had the wrong output shaft in. It was an output shaft for a 205. And I needed the shorter shaft for a 203. So i got a new shaft and and tore down the 400. When i was putting it back together i had a bit of an issue put the input/stator shaft back in. Just seemed like it was catching the 3rd gear drum clutches in a funny way. So i pulled it back out and pulled the 3rd gear drum out and noticed that i bent some of the teeth the on one of the clutch discs. So in my cave man ways i tried to straighten them out, well i ended up breaking two of the teeth of the clutch disc. I said fark it, it cant be that bad and reassembled it. This time everything went in just out it should. But now I am second guessing myself. Is it bad if one of the clutches is missing two of its teeth? Seems to me that it shouldnt make much of a difference seeing that there are a lot of teeth on each clucth.

Let me know if i can run it this way or I should buy a new clutch pack and replace them.

Thanks

Paul
11-07-2011 05:28 PM
44boggers ah no worries. I was able to pick up a valve body cheap i will swap in. yeah the axle came out great, Just need to order inner shafts and gears.
11-07-2011 05:21 PM
koolk10 looking good. i scrapped a th400 about 3 weeks ago.i wish i knew you needed it.
11-07-2011 01:58 PM
44boggers WH70 axle completed!! Th400 is just about done, waiting on a different valve body.
11-05-2011 07:23 PM
44boggers Hey guys, Im nearly done with my th400 build but one of my valves in the valve body was all pitted, must of gotten a little too hot. Wondering if anyone has a use th400 valve body they want to get rid of.

Let me know, thanks

Paul
This thread has more than 25 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 10:38 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.