Anyone done a PSC pump install... - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Toyota - Formula Toy Forum
Notices

Reply
 
Share Thread Tools Display Modes
Old 06-29-2006, 11:48 AM   #1 (permalink)
Wheeler
 
Join Date: Dec 2005
Member # 62881
Location: Salinas, California
Posts: 268
Anyone done a PSC pump install...

Planning on putting on my psc hi flow kit this weekend and wondering if anyone who has done it has run into any problems of note...
Thanks...
VasToyBoy is offline   Reply With Quote
Old 06-29-2006, 12:06 PM   #2 (permalink)
Pirate4x4 Addict!
 
DOUG38S's Avatar
 
Join Date: Feb 2003
Member # 17107
Location: Sharpsburg, MD
Posts: 5,578
Blog Entries: 1
Send a message via AIM to DOUG38S
I've helped and seen it done. Contact Jamison Workshop. He's usually in the toy area and just did his on his new buggy. His works great.
__________________
BIGELOW MOTORSPORTS #4413
DOUG38S is offline   Reply With Quote
Sponsored Links
Old 06-29-2006, 02:16 PM   #3 (permalink)
Wheeler
 
Join Date: Dec 2005
Member # 62881
Location: Salinas, California
Posts: 268
Thanks for the info. Guess now I have to do it
VasToyBoy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.