braking problems - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Toyota - Tacoma
Notices

Reply
 
Share Thread Tools Display Modes
Old 07-30-2007, 07:23 AM   #1 (permalink)
Registered User
 
Join Date: Feb 2007
Member # 86672
Posts: 67
braking problems

I did my swap a little over a month ago and i am still having troubles wiht my brakes. from day one the calipers i bought from NAPA were not able to float properly. we did some grindign on them and the steering arms because that is what they were hitting to make them clear better but i am not sure that is the problem. now under normal braking pressure i get a terrible shake until 47mph, my speedo is way off, and then it just stops immediately at that speed. when i say shake i mean the front end of the truck feels like it wants to come off the truck. i am hoping you guys can help diagnose my problem. is it the caliper floating issue or somethign else? i am not entirely sure they are the right calipers because they were shaped differently than each other and didnt seem like a matching pair but i threw them on there anyways because the part guy said they were right. also it doesnt happen every time. if i brake lighter or harder than usual it seems to help but no matter what it always goes from violent shaking to smooth instantly at 47mph. some specs are in my signature but i have sky tall arms and that is what they are hitting. thanks for your input.
also is anyone else having problems clearing calipers on skys arms and know of a smaller caliper that would work on a waggy front axle?
__________________
SFA Taco with a waggy D44, 4.88s, locked front and rear, and 36" TSLs

Last edited by tacoma87; 07-30-2007 at 07:23 AM.
tacoma87 is offline   Reply With Quote
Old 07-30-2007, 07:25 AM   #2 (permalink)
Registered User
 
Join Date: Jun 2006
Member # 74729
Location: Mesa, AZ
Posts: 38
what does speedo have to do with it?
post pics of your set-up so people can see a possible problem.
AZTBob is offline   Reply With Quote
Sponsored Links
Old 08-02-2007, 04:57 PM   #3 (permalink)
Registered User
 
Join Date: Nov 2005
Member # 56682
Location: VACAVILLE, NOR CAL
Posts: 286
Send a message via AIM to GOOBAWIGGA
[QUOTE=AZTBob;7066395]what does speedo have to do with it?

He doesn't know how fast he is really going.
__________________
Work in progress: 60/14B, 42 irocks, 44044 fronts, 63" chevys in the rear, marlin taco dual cases 4.7s in the rear, 111" wheelbase. lots of pipe four seats and what ever is left of the body
dp4x4 bay area, california
SAVE THE HAMMERS!!!! # 476:smokin:
[url]http://teamdp4x4.com/[/url]
GOOBAWIGGA is offline   Reply With Quote
Old 08-06-2007, 06:35 AM   #4 (permalink)
Registered User
 
Join Date: Feb 2007
Member # 86672
Posts: 67
just an update...i got my new 37s on and the problem went away. i dont know if it was because of the tires or now my truck just cant stop as well because of the extra tire weight but either way it went away...
__________________
SFA Taco with a waggy D44, 4.88s, locked front and rear, and 36" TSLs
tacoma87 is offline   Reply With Quote
Reply





Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:49 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.