93 Crew Cab Build "Brown Truck" - Page 3 - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Ford
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 06-25-2018, 02:50 PM   #51 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Been a long time without much to brag about on this pile. I slapped a fitech efi system on it. Put a couple new TSLs on the back. Replaced front leaf springs (old ones were bent, off a gasser 04 f250 i think). EFI system didn't like the old gas tank configuration, so I put a fuel cell on, which helped tremendously. Runs pretty awesome now. I'm in the process of building a shitty flat bed. Hope to get a few more good runs out of it before I get the urge to scrap it and build a new one.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 06-25-2018, 02:53 PM   #52 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
[IMG]0508182141a by oldasspops[/IMG]

I'll post some more pics once I get the flatbed "finished"
Wmarcom is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 06-27-2018, 02:08 PM   #53 (permalink)
Rock God
 
snowracer's Avatar
 
Join Date: Sep 2009
Member # 141697
Location: Great White North aka BC Canada
Posts: 2,181
awesome to see updates on this, keep them coming
__________________
PLAN-B F250 on 44s

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
snowracer is offline   Reply With Quote Quick reply to this message
 
Old 06-27-2018, 03:44 PM   #54 (permalink)
Rock God
 
whitneyj's Avatar
 
Join Date: May 2009
Member # 135947
Location: Oshkosh, WI
Posts: 2,369
What he said^^

Iíve always had dreams of building a CCSB F350 into a family wheeler/general use truck.
__________________
Place banana in your ear.
Observe that there are no alligators around.
Conclude bananas placed in ears keep alligators away.
whitneyj is offline   Reply With Quote Quick reply to this message
Old 06-28-2018, 07:57 AM   #55 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Quote:
Originally Posted by whitneyj View Post
What he said^^

Iíve always had dreams of building a CCSB F350 into a family wheeler/general use truck.
Don't follow that dream. I did and my family doesn't give a damn about it. May as well have built a 2 seater. On the otherhand, DO build a big ass CC if you are single because you could fit tons of sloots in there and the gooseneck hitch makes for a dandy stripper pole accessory.

Anyway, last night I took some extra lumber from work and slapped them on the bed. This new feature has motivated me to get functioning tail lights so I can try to get some TX Antique tags. If I could legally drive this to the beer store I think I'd enjoy this turd 100% more. For the past 4 years it is just a big ugly POS that I have to see in my garage.

[IMG]0627182133[/IMG]

[IMG]0627182133a[/IMG]
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 06-28-2018, 04:19 PM   #56 (permalink)
Rock God
 
snowracer's Avatar
 
Join Date: Sep 2009
Member # 141697
Location: Great White North aka BC Canada
Posts: 2,181
missed it the first time but just seen you said you are running the Fitech efi, how do you like it? i have it for my bbf and about to fire for the first time in a few days. have seen some horror stories on the system so little worried
__________________
PLAN-B F250 on 44s

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
snowracer is offline   Reply With Quote Quick reply to this message
Old 06-29-2018, 01:00 AM   #57 (permalink)
Registered User
 
Join Date: Sep 2008
Member # 120478
Location: San Jose, CA
Posts: 1,288
Quote:
Originally Posted by Wmarcom View Post
If I could legally drive this to the beer store I think I'd enjoy this turd 100% more. For the past 4 years it is just a big ugly POS that I have to see in my garage.
It may sound dumb but it can be motivating to drive your wheeler around town! I've gone to lengths to keep mine registered and legal and such. Would've been much easier not to but its fun to drive. So I'll give a thumbs up encouragement to get it legal and drive it more!
__________________
Wheeler ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
90 Bronco with stuff
Dan90FSB is offline   Reply With Quote Quick reply to this message
Old 06-29-2018, 09:15 AM   #58 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Quote:
Originally Posted by snowracer View Post
missed it the first time but just seen you said you are running the Fitech efi, how do you like it? i have it for my bbf and about to fire for the first time in a few days. have seen some horror stories on the system so little worried
As much as I bitched about the fitech not running worth a shit, it was really all due to my fuel pump not being able to draw fuel out of the factory tank. Once I put a fuel pressure gauge on there it was very obvious. It was easy as hell to install. It idles fine. Now that I have a fuel cell it has plenty of power. The only thing I find irritating is that it needs an absolutely good battery to start. If the voltage drops while cranking, the injectors won't fire. This is a real pisser on the trails.

Scenario time - I had a weak battery but the thing started fine on the trailer, went wheeling around some, motor died while climbing out of a creek, tried to crank it and it wouldn't start at all. After dicking around checking spark, fuel, etc. we tried jumping it. Motor cranks fine, but noticed voltage dropped significantly while cranking. So, we put two jumpers on it and used some starting fluid and it fired right up.

Basically, the battery may be charged enough to crank the motor, but not have enough juice to keep the fitech happy - therefore it wont start. Now I keep some starter fluid around (and maintain a good battery) and that gives it a little boost to fire up. I am sure this can be fixed in the settings but I am too busy and dumb to attempt to mess with it at this time.

Other fitech details: 600 hp setup, using some walbro pump (forgot which one), timing not being controlled by fitech - just using HEI now. now that it has fuel delivery sorted out, I give it a thumbs up.


I plan on getting the title transferred next week and applying for antique tags. Need to figure out turn signals n sheeeeitttt now. I might get drunk tonight and get creative. Being able to take this cruising around would definitely motivate me to do more with it.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 06-29-2018, 10:37 AM   #59 (permalink)
Rock God
 
snowracer's Avatar
 
Join Date: Sep 2009
Member # 141697
Location: Great White North aka BC Canada
Posts: 2,181
i went with the Fitech inline pump and its mounted on the frame about 6-8 inches below the fuel cell so should be ok there. im also running dual yellow tops and a 130 amp alternator so hope i dont run into the same issues as you.
__________________
PLAN-B F250 on 44s

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
snowracer is offline   Reply With Quote Quick reply to this message
Old 06-29-2018, 12:25 PM   #60 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
I might add that i dont need starter fluid unless battery voltage gets too low and i am running a POS orielly special battery that has been replaced 3 times under warranty. You should be golden.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 12-12-2018, 09:19 AM   #61 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Update: Since the last post, I have been making some headway. It started with reworking the old caddy heads. New, larger valves have been installed along with a bit more port work to blend in the runners. Also port matched the edelbrock intake a bit.

[IMG]

[IMG][url=https://flic.kr/p/2dwknzB]

[IMG][url=https://flic.kr/p/2dwknCn]



The fitech system was giving me fits. Long story short it was a damn fuel filter that was the last thing I did to finally get the thing running right. So now with a happy fuel system, and much better flowing heads, along with better valvetrain setup, this thing is simply scary to drive.

[IMG][url=https://flic.kr/p/2dwknv8][/IMG]


[IMG][url=https://flic.kr/p/2cqoYno][/IMG]

[IMG][url=https://flic.kr/p/2cqoYdf][/IMG]

After a few hoon sessions I ended up flopping it over in a field like an idiot, so AFTER that we started working on a simple roll cage. It is ugly but should serve me well. Nothing is straight or level since the frame isn't true and the cab is knocked all wonky, so don't look at it too hard. Also, don't pay attention to the total lack of triangulation. Rome wasn't built in a day. I'll be adding some more tube as soon as I get the chance.

I also installed my old PRP seats, relocated the battery to the bed, lag bolted some hooks in the bed boards to hold the important things like a cooler, rewired things and used fuses this time (looks awful in the pics, has been cleaned up), replaced the shitty HF winch with a nicer shitty HF winch, and got the antique tags so I can cruise the boulevard!

[IMG][url=https://flic.kr/p/2cqoYh3][/IMG]


[IMG][url=https://flic.kr/p/2dwknnH][/IMG]

[IMG][url=https://flic.kr/p/2dwkn7n][/IMG]

[IMG][url=https://flic.kr/p/2cqoYjh][/IMG]



This weekend is the debut trip to Clayton, OK. So I will update with some good pictures next week. Fingers crossed. I haven't worked on this pile this much since about 4 years ago and it never was running worth a shit till now. I'm pretty stoked now that it can light up the tires.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 12-12-2018, 09:36 AM   #62 (permalink)
Rock God
 
whitneyj's Avatar
 
Join Date: May 2009
Member # 135947
Location: Oshkosh, WI
Posts: 2,369
Am I the only one that can't see these pictures?
__________________
Place banana in your ear.
Observe that there are no alligators around.
Conclude bananas placed in ears keep alligators away.
whitneyj is offline   Reply With Quote Quick reply to this message
Old 12-12-2018, 09:55 AM   #63 (permalink)
today
 
fredycruger's Avatar
 
Join Date: Aug 2012
Member # 225557
Location: MA
Posts: 1,447
yup
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
fredycruger is offline   Reply With Quote Quick reply to this message
Old 12-12-2018, 03:32 PM   #64 (permalink)
Rock God
 
snowracer's Avatar
 
Join Date: Sep 2009
Member # 141697
Location: Great White North aka BC Canada
Posts: 2,181
Quote:
Originally Posted by whitneyj View Post
Am I the only one that can't see these pictures?
i can see them just fine and ill tell you that you are missing out as this truck is all kinds of cool
__________________
PLAN-B F250 on 44s

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
snowracer is offline   Reply With Quote Quick reply to this message
Old 12-13-2018, 08:55 AM   #65 (permalink)
Registered User
 
AllGoNoShow's Avatar
 
Join Date: Apr 2005
Member # 46318
Location: South Dakota
Posts: 2,964
I love it, I sooooo much want to build a obs crew some day. Keep the pics coming.
__________________
Vote Trump 2016.
AllGoNoShow is offline   Reply With Quote Quick reply to this message
Old 12-13-2018, 06:57 PM   #66 (permalink)
nice roach.
 
jhama78's Avatar
 
Join Date: Feb 2001
Member # 3377
Location: Eastern Shore, Va
Posts: 5,708
Love a good beater full size rig with too much Caddy torque. Looking forward to updates.
__________________
-j-rOd

wear life like a loose garment

84 Toy Farm Beater
88 4Runner Beach Ride
11 Tundra Double Cab Rock Warrior
jhama78 is offline   Reply With Quote Quick reply to this message
Old 12-16-2018, 06:59 PM   #67 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Made it through the weekend with zero mechanical issues. The shit missile surprised some folks on the trail. Lots of power on tap and a schoolbus's wheelbase made for some fun climbs. I got a few pics that i will post soon. All the doors still open and shut. Blasted out the rear driver side window by crunching into a tree. Only one more door window left.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 12-16-2018, 07:07 PM   #68 (permalink)
Registered User
 
Join Date: Nov 2014
Member # 515673
Posts: 175
Fuck I can’t see the pictures either.
EJXJ is offline   Reply With Quote Quick reply to this message
Old 12-18-2018, 03:40 PM   #69 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
Ok, so Clayton was badass as usual. The truck did great. We had a truckload of passengers so the trail riding was more of a pleasure cruise than an all out trail beating, but the truck performed great all weekend. We even wired up the windshield wipers. The only damage was cosmetic, which I can't even call it damage. The looks just keep improving IMO.

Picture time in no particular order












It was rainy!





Thats about all I have. Overall it was a blast and I'm really happy I didn't have to spend any time wrenching on the trail. Not sure what I have in mind to change at this point. Hopefully next update will just be more trail pics.

Also, thanks for all the comments. I do appreciate the feedback! This is pretty much the only pirate forum I even check on anymore. I know it's slow but you guys have some badass projects.
Wmarcom is offline   Reply With Quote Quick reply to this message
Old 12-18-2018, 04:03 PM   #70 (permalink)
Rock God
 
snowracer's Avatar
 
Join Date: Sep 2009
Member # 141697
Location: Great White North aka BC Canada
Posts: 2,181
great trail pics and that looks like a wicked place to wheel

so got to ask about how you wired up the wipers as was just thinking about that on my truck this morning. you still running the stock wiring for the motor and switch or bypassed all that. i have non of the stock stuff to make it work so need to look at the diagrams and see if can just hard wire to a switch
__________________
PLAN-B F250 on 44s

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
snowracer is offline   Reply With Quote Quick reply to this message
Old 12-18-2018, 05:07 PM   #71 (permalink)
Registered User
 
Join Date: Aug 2014
Member # 492169
Location: Bryan/College Station, TX
Posts: 61
I googled a diagram and was able to make it work just by using a switch 12v+ to one terminal and a ground on another. Apparently there are a couple types of motor versions. One has 6 total terminals (2 connectors with 3 terminals ea) and the updated one has 5 terminals. It wasn't hard to do, but I only used one speed (high) and i didn't attempt to wire it to use the park function. Making it work like factory may not be that difficult but I was in a hurry and hung over doing this in the rain with shitty cell service. Haha!
Wmarcom is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.