GM LS2 running temperature - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > General 4x4 Discussion
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 04-25-2012, 01:16 PM   #1 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 197154
Posts: 11
GM LS2 running temperature

Hi everybody,

Got a rally-raid rig with GM LS2 from TurnKeyEngineSupplies installed. Bob Radke (mefiburn.com), who tuned the engine, said it's good if the engine's not hotter than 95C/203F, worse if it is. The problem is during the race I usually have it running around 105C/221F and it can last for hours.

As I read here and somewhere else there's a lot of people who run their LS's at such temperatures. Is Bob overcautious or shall we all end up with broken engines? Please help. Thanks!

ALFA test 240312 - YouTube
Doos is offline   Reply With Quote Quick reply to this message
Old 04-25-2012, 01:28 PM   #2 (permalink)
Rock God
 
SVARAS's Avatar
 
Join Date: Jan 2002
Member # 9310
Location: Chile
Posts: 1,556
I cannot tell for Aluminum block, but my iron block 6.0 (LY6) loves to run at 210 all time.
Never had a problem with that temp.
__________________
4WOR 2012 Ultimate Adventure Invited Reader
Willys MB LSX 2013
SVARAS is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 04-25-2012, 01:32 PM   #3 (permalink)
Wheeler
 
Join Date: Nov 2003
Member # 24678
Location: YARRR, Crawlorado
Posts: 569
Send a message via AIM to TensoR Send a message via Yahoo to TensoR
my gmpp ls2 runs no hotter than 210 during races as long as the fans are spinning, the wife forgot to turn them on once when she took it out alone and it got over 240, no issues.

my previous rigs have all run around 205-210 on other engines as well.
__________________
I was enslaved as a circus freak to entertain you drunken monkeys

Rogue Rock Racing #701


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by TensoR; 04-25-2012 at 01:33 PM.
TensoR is offline   Reply With Quote Quick reply to this message
 
Old 04-26-2012, 11:00 PM   #4 (permalink)
Registered User
 
Join Date: Aug 2011
Member # 197154
Posts: 11
Thanks guys!
Doos is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.