premier power welder - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > General 4x4 Discussion
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 11-26-2001, 08:51 PM   #1 (permalink)
Registered User
 
Join Date: Nov 2000
Member # 2189
Location: San Andreas,CA
Posts: 131
premier power welder

Who has bought one lately, and how do you like it (good and bad). What Amp did you get and how did it weld.
badfish is offline   Reply With Quote Quick reply to this message
Old 11-27-2001, 12:18 AM   #2 (permalink)
Registered User
 
Join Date: Apr 2001
Member # 3979
Location: redding, ca
Posts: 985
I got one a year ago. 160 amp altenator. It welds pretty nice; but i haven't really used it much as I took it out of the rig I had it in because I sold it. I've been planning on putting it in another rig but haven't got around to it. My only complaint is that the altenator is noisy(hi pitched whine) which was compounded by the fact that the rig I had it in had 5.57 gears and no overdrive with 36" tires.........the high RPM while freeway driving increased the noise of the altenator. At low RPM during around town driving it was no big deal.
roverhybrids is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 11-27-2001, 07:29 AM   #3 (permalink)
Registered User
 
Lucy's Driver's Avatar
 
Join Date: Jun 2001
Member # 5124
Location: New York, NY
Posts: 369
I put one in about a year ago. The alt does make a bit of noise, but not bad. At first I thought I had bad bearings in there though.
I kind of went though a major PITA with it - pulled the old crap, installed the whole deal (including relocating a bunch of stuff under the hood), fired it up - and the alternator wasn't charging the battery.
Dealt with PPW on it, they overnighted me a new alt that day (I sent back the old one later), swapped that one in, been fine since.
Welds really nice.
__________________
"Your Jeep smells like a sweaty horse." 8/24/01, "Get me out please, I'm upside down, I smell gas." 9/29/01
Lucy's Driver is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.