Compatibility - L92 VVT motor with Turbo 400 - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > General 4x4 Discussion
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 11-14-2018, 09:43 AM   #1 (permalink)
Rock God
 
jeep09's Avatar
 
Join Date: Oct 2009
Member # 143697
Location: Buy the C
Posts: 1,953
L92

Compatibility
__________________
____________________
2017 Jimmys Buggy

12v Chase Truck

LS Jeep on Tons
Team 4485 Genright

Last edited by jeep09; 11-22-2018 at 05:53 AM.
jeep09 is offline   Reply With Quote Quick reply to this message
Old 11-14-2018, 09:58 AM   #2 (permalink)
Wheeler
 
Twankie's Avatar
 
Join Date: Oct 2012
Member # 230823
Location: Alvin TX
Posts: 305
Compare the trans settings with a similar equipped car with a manual transmission.
Twankie is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 11-14-2018, 10:02 AM   #3 (permalink)
Zeus of the Sluice
 
TrailTamer XJ's Avatar
 
Join Date: Aug 2009
Member # 140878
Location: Fawkin NY
Posts: 2,898
My first few thoughts; do you have the VSS hooked up? What ECM you’re running? Accordingly to PSI Conversion you’re suppose to be running a E38 ECM.

Edit: unlikely but; have you or your tuner confirmed that your pedal is working correctly? (0-100%, or it stops at 53%?)

Last edited by TrailTamer XJ; 11-14-2018 at 10:03 AM.
TrailTamer XJ is offline   Reply With Quote Quick reply to this message
 
Old 11-14-2018, 10:16 AM   #4 (permalink)
GiS
Registered User
 
GiS's Avatar
 
Join Date: May 2004
Member # 31285
Location: Canada Eh!
Posts: 2,759
I think something simple is being overlooked, or you and your tuner are heading down the wrong path?

Can you confirm you are running the E38 ECM? Also, what pedal are you using, what application did it come from?

Did you keep the factory 87mm Throttle Body?
__________________
Rock Posse Racing #686
Driver: Joey Weber
GiS is offline   Reply With Quote Quick reply to this message
Old 11-14-2018, 10:23 AM   #5 (permalink)
Registered User
 
Join Date: Nov 2001
Member # 7903
Location: SE Michigan
Posts: 4,424
Do the ECM, the OS you are using, the throttle body, and pedal all match?



Sent from my SM-G950U using Tapatalk
JohnnyJ is offline   Reply With Quote Quick reply to this message
Old 11-14-2018, 04:54 PM   #6 (permalink)
Rock God
 
jeep09's Avatar
 
Join Date: Oct 2009
Member # 143697
Location: Buy the C
Posts: 1,953
Quote:
Originally Posted by GiS View Post
I think something simple is being overlooked, or you and your tuner are heading down the wrong path?

Can you confirm you are running the E38 ECM? Also, what pedal are you using, what application did it come from?

Did you keep the factory 87mm Throttle Body?
E38 ECM - correct for L92
Factory pedal (new) - 2007 Escalade
Factory throttle body
__________________
____________________
2017 Jimmys Buggy

12v Chase Truck

LS Jeep on Tons
Team 4485 Genright
jeep09 is offline   Reply With Quote Quick reply to this message
Old 11-14-2018, 04:56 PM   #7 (permalink)
Rock God
 
jeep09's Avatar
 
Join Date: Oct 2009
Member # 143697
Location: Buy the C
Posts: 1,953
Quote:
Originally Posted by Twankie View Post
Compare the trans settings with a similar equipped car with a manual transmission.
This is the rub, no VVT manual cars were made. I am missing the signal or "tune mod" from the 6L80
__________________
____________________
2017 Jimmys Buggy

12v Chase Truck

LS Jeep on Tons
Team 4485 Genright
jeep09 is offline   Reply With Quote Quick reply to this message
Old 11-14-2018, 07:08 PM   #8 (permalink)
Registered User
 
Join Date: Nov 2001
Member # 7903
Location: SE Michigan
Posts: 4,424
Quote:
Originally Posted by jeep09 View Post
E38 ECM - correct for L92
Factory pedal (new) - 2007 Escalade
Factory throttle body
Just to be clear since I've seen people get burned.. a 2007 truck throttle body; not one from a Vette?
JohnnyJ is offline   Reply With Quote Quick reply to this message
Old 11-15-2018, 06:37 AM   #9 (permalink)
Rock God
 
jeep09's Avatar
 
Join Date: Oct 2009
Member # 143697
Location: Buy the C
Posts: 1,953
Quote:
Originally Posted by JohnnyJ View Post
Just to be clear since I've seen people get burned.. a 2007 truck throttle body; not one from a Vette?
yes, its a truck TB
__________________
____________________
2017 Jimmys Buggy

12v Chase Truck

LS Jeep on Tons
Team 4485 Genright
jeep09 is offline   Reply With Quote Quick reply to this message
Old 11-15-2018, 06:45 AM   #10 (permalink)
Rock God
 
Join Date: Jun 2010
Member # 161937
Location: Discovery Bay, CA
Posts: 1,599
I agree something is getting overlooked. Your tune should even deal with torque management. I would have to look at my tune and cross reference OS numbers. I have a l92 that use to be paired to a 6l80 and then switched to 4l80. I believe the tune needs to be built off a base file such as a corvette with a manual trans.
__________________
5.3 TJ linked on ROCKS, ORI's, and 47's ***sold***
U4 buggy

Thanks to:
PCI Radios
BTR Wheels
BF Goodrich
jrad12381 is offline   Reply With Quote Quick reply to this message
Old 11-15-2018, 06:57 AM   #11 (permalink)
Rock God
 
jeep09's Avatar
 
Join Date: Oct 2009
Member # 143697
Location: Buy the C
Posts: 1,953
Quote:
Originally Posted by jrad12381 View Post
I agree something is getting overlooked. Your tune should even deal with torque management. I would have to look at my tune and cross reference OS numbers. I have a l92 that use to be paired to a 6l80 and then switched to 4l80. I believe the tune needs to be built off a base file such as a corvette with a manual trans.
That was reviewed with my tuner, Corvettes didn't come with VVT is apparently the issue
__________________
____________________
2017 Jimmys Buggy

12v Chase Truck

LS Jeep on Tons
Team 4485 Genright
jeep09 is offline   Reply With Quote Quick reply to this message
Old 11-15-2018, 07:39 AM   #12 (permalink)
Zeus of the Sluice
 
TrailTamer XJ's Avatar
 
Join Date: Aug 2009
Member # 140878
Location: Fawkin NY
Posts: 2,898
I think the most logic next step is to contact PSI Conversion’s tech support. I’d imagine they have an answer because they sold you a harness specifically for either manual or non-computerized transmissions.
TrailTamer XJ is offline   Reply With Quote Quick reply to this message
Old 11-15-2018, 08:05 AM   #13 (permalink)
Registered User
 
Join Date: Aug 2007
Member # 97574
Posts: 3,255
What is pcm out of and what base tune?

I run a built L92 out of an 07 escalade with a th350 behind it with no issues. Either wrong base file or the tuner is missing something.
__________________
https://www.facebook.com/groups/OFFROADCNCFILESHARING/
ROXROES is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.