Anyone ever use a Honda 3.5L in a buggy? - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > General 4x4 Discussion
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 01-12-2006, 01:50 PM   #1 (permalink)
UTVGuide.net
 
Crowdog's Avatar
 
Join Date: Jan 2001
Member # 2787
Location: Shingle Springs, CA
Posts: 2,826
Anyone ever use a Honda 3.5L in a buggy?

Thinking about using a 3.5L Honda in a front engine off-road vehicle (sand dunes & desert). The 3.5L is used in a lot of rear engine (transaxle) sand rails.

Anyone here use a Honda in a rock crawler?

What manual/auto transmission setups may work?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Crowdog; 01-12-2006 at 04:23 PM.
Crowdog is offline   Reply With Quote Quick reply to this message
Old 07-23-2006, 10:14 PM   #2 (permalink)
Fabster
 
Randy's Avatar
 
Join Date: Jan 2001
Member # 3069
Location: Gardnerville NV
Posts: 2,528
dont have any tec to add just think that this engine has potetule and think its worth talking about.
__________________
Thanks for the support

Currie Enterprises
PSC Steering
BFGoodrich Tires
Reid Racing
King Shocks
Trail Ready Wheels
Baja Designes
K&N
CBM Engines
Bulldog Winch
Spidertrax
Maximum Trans
CBR Radiator
PRP seats
Steinjager
PCI
208 Motorsports

2015 KING
2013 KING


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Randy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.