78 jeep cherokee tracking issue - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 04-29-2013, 07:06 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2012
Member # 208824
Posts: 2
78 jeep cherokee tracking issue

Although its not unibody I have a question that hopefully someone here can help me answer. I have a 4" BDS Spring lift and just recently moved my shackles on front of vehicle to rear. I positioned my shackle mounts in frame with. 125" dom and new urethane bushings all the way around. Built fixed mounts for front out of 3/8 plate. Everything is great except the axle tracks left and right badly. My best guess is I need a track bar (doesnt have one). Prior to this reversal I had wornd out bushings and lighter mounts
and shackles. Why do I now have this problem. Thanks for input
Frostbit169 is offline   Reply With Quote Quick reply to this message
Old 04-30-2013, 07:38 AM   #2 (permalink)
Moderator
 
ashmanjeepXJ's Avatar
 
Join Date: Feb 2002
Member # 10249
Location: Vail, Arizona
Posts: 5,599
Did you shim your leaf spring perches for the change in angle? what is your caster angle set to?

If your caster is off the axle will wander all over, it will not want to return to center when you let go of the wheel and will do other strange things.
__________________
Dave
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

AZ Undertaker
ashmanjeepXJ is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 04-30-2013, 06:20 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2012
Member # 208824
Posts: 2
Caster is 5 to front pinion angle is 10. I built my fixed mounts to maintain same angles I had before. I forgot to point out I extended my axle forward 5" during this process. My main issue is the amount of travel the axle has from left to right when wheel is turned from a dead stop
Frostbit169 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.