No power & other - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Land Rover
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 05-15-2014, 06:20 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2005
Member # 50619
Posts: 66
No power & other

95 RRC
I've got crap power, will drop to 45mph in 3rd gear on hills. Backfire/pop through intake (can hear it through snorkel). The backfire and really bad power came immediately after new O2;s.

Idles great. No CEL. Autologic not showing anything funny.
Maybe 5k miles on dizzy, amp, coil
New plugs, wires, rotor, cap
New coolant temp sensor
Timing good
swapped MAFs
Vacuum advance working
Compression 160ish except #4 is 147. Dry
Vacuum is low at 15 Hg, but steady. Smoked for leaks...None.
Vacuum advance working
Fuel pressure/pump good.
Pressure regulator good
No cats to be clogged
No fluid mixing/pressure issues

I assume Autologic would pick up a bad VSS.

I'm open to suggestions!!
__________________
96 DI, 03 DII, 04 DII-Traded
95 RRC SWB, 76 FJ40 - I needed another reason to beat my dog!

Last edited by flyfish; 05-15-2014 at 06:48 PM.
flyfish is offline   Reply With Quote Quick reply to this message
Old 05-15-2014, 10:28 PM   #2 (permalink)
Registered User
 
Join Date: Feb 2005
Member # 42753
Location: New Zealand
Posts: 1,721
Stick a wideband O2 sensor up the exhaust and see what it's doing.
Dougal is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 05-16-2014, 04:18 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2005
Member # 50619
Posts: 66
I'm embarrassed to say it ended up being bad brand new ignition parts and custom timing diagnosed by our local rover tech.

Kinda ridiculous.
__________________
96 DI, 03 DII, 04 DII-Traded
95 RRC SWB, 76 FJ40 - I needed another reason to beat my dog!

Last edited by flyfish; 05-16-2014 at 04:25 PM.
flyfish is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.