Pirate4x4.Com : 4x4 and Off-Road Forum - View Profile: murphm777
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Members List
Notices

murphm777 murphm777 is offline

Registered User

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. mtc765
    10-20-2016 06:12 AM - permalink
    mtc765
    314-541-3781 , all works good, probably need a e-brake cable and or pads, the cable is at the end of its adjustment, you have to pull the lever all the way up to get brake set to hold on steep hills, in the driveway it holds fine. Its always had synthetic oil and I can now see the area around the valve cover is darker, might indicate a new cover gasket sometime in the future, no leaks on the garage floor, and never uses oil. I'd say the driver seat is about the only thing showing its age, it just doesn't have the lateral support for a weekend of trail riding.

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 07-21-2019 08:02 AM
  • Join Date: 10-17-2016

Mentions

No results to display...

Quotes

No results to display...

All times are GMT -7. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.