Pirate4x4.Com : 4x4 and Off-Road Forum - Reply to Topic
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > Brand Specific Tech > Jeep - Non Hardcore > lockrite ????'s
Notices

Thread: lockrite ????'s Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-21-2006 11:17 AM
SlowMo I have a Locrite in my D-30 and the Posi-Locker cable that replaces the vacuum lines at the disconnect. If I engage the Posi-Locker when in 2 wheel drive (which would be similar to how a TJ would run in 2wd since they have a solid axle in lieu of the disconnect) I do feel the locker slightly. Its not a big deal, but I can tell it's there. When I switch to 4wd then I can really tell its there, and that's a good thing.
03-21-2006 07:51 AM
fyrfyter43
Quote:
Originally Posted by SlowMo
When I insalled mine I read in the instructions from Richmond Gear that they recommend NOT running them in the front axle of a street driven vehicle that has full time engagement
They're talking about a vehicle with full-time 4WD.

I run an Aussie in my D30, and don't notice it's there on the street except for some light clicking around turns.

Look in the vendor section. The rep from Aussie had a pretty long thread in there, and should be able to answer any questions you might have.
03-21-2006 02:03 AM
XJMarty I mean:

E-Z is 50$ cheaper than a lockright, I mean if lockright is worth the 50$ more?

I would like EZs as the are cheaper, but dont want to buy a piece of junk especially when shipping to europe is costly and takes long time
03-20-2006 10:20 AM
XJMarty ok, i have a part time, so i do not run 4wd on streets ....

but i meant if ony of them is any better than the others?
03-20-2006 07:09 AM
wvredxj yes it works, and yes you will hear it........and feel it if you have the desire to run it in 4wd on the street.
03-20-2006 06:57 AM
XJMarty I have a similar question:

I want lock D30 and D35 on my XJ, is there eny difference in the performance between E-Z, Aussie, Lockright or No-slip? I mean both on and off road
03-18-2006 02:35 PM
TJ_LoSeR Yeah I can lift my 35 off the ground about 2 ft. Thanks for the help and the info fellas! Keep the info coming!
03-18-2006 12:01 AM
jeep_freek
D30 with Lockrite...

Quote:
Originally Posted by TJ_LoSeR
I have a D30 front axle and was wondering if anybody has ran a lockrite locker without lock out hubs?

Thanks for the help!
I have a '99 TJ with a Dana 30 in the front and have added a Lockrite in it as well. It works awesome off-road. When it's on the road, it's as if it's not even there. It's about the perfect locker in a front diff. It won't lockup unless your in 4wd.

Here's a small video my girlfriend took of me doing some wheelies in a parking lot. This is in 2wd. I've never locked it in on a hard surface.

http://www.brucester.net/ftp/temp/01-29-06-01.MPG
(this has nothing to do with the locker, but was fun anyways.) There were more wheelies & much higher than this, then she started recording.

Here's a bonus: It's cut from another movie I found online.
http://www.brucester.net/ftp/temp/wheelie.wmv
03-17-2006 09:58 PM
OhioYJ The locker won't be locked until there is load on it, so in 2WD you won't notice it.
03-17-2006 03:24 PM
Ex CCS Racer I had one in my '94 YJ and now in my '98 XJ. No probs what so ever. In my YJ I was a little hard on it and broke the u-joint, outer, the shaft, and the ball-joints and the locker held together perfectly.
03-17-2006 03:10 PM
TJ_LoSeR thanks for all the info
03-17-2006 02:31 PM
pcoplin You'll have no problems. You won't even notice it's there.
03-17-2006 02:15 PM
jeepcjsc i know of several tj's running them with zero problems i had one in my cj dana 30 with lockouts of course and it worked great and now i have one in my D44 with no problems either
03-17-2006 01:00 PM
SlowMo I've been running them in my 95 YJ D30 for a couple of years now. But the YJ D30 is different than the TJ D30. The YJs came with the vacuum disconnect on the right axle shaft while the TJs have a one piece solid axle. So it works well for me. When I insalled mine I read in the instructions from Richmond Gear that they recommend NOT running them in the front axle of a street driven vehicle that has full time engagement (ie. no lock out hubs or disconnect). On the other hand, I've heard of TJ owners who swear they can't tell they're in there (until they go to 4 wheel drive of course).
03-17-2006 12:53 PM
DutchTJ
Quote:
Originally Posted by TJ_LoSeR
I have a D30 front axle and was wondering if anybody has ran a lockrite locker without lock out hubs?
yes (actually the Noslip which is the other Powertrax locker) and no problems.
Now I have that Noslip in the HP30 with Warn hubs and still (KOW) no problems

You won't notice the locker in the front of a TJ when you're in 2wd
03-17-2006 12:23 PM
kris1351 Why would you waste the money on lockouts for a D30????

The lock right works great in a D30 and is a cheap way to lock it up and forget about it. You will break the carrier before you break the locker. As for running with lockouts why would there be a problem? You are actually making it so it doesn't turn when the vehicle is in motion unless it is locked in.
03-17-2006 12:08 PM
TJ_LoSeR
lockrite ????'s

I have a D30 front axle and was wondering if anybody has ran a lockrite locker without lock out hubs?

Thanks for the help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -7. The time now is 11:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.