International crew cab race truck hauler & toy hauler build - Page 4 - Pirate4x4.Com : 4x4 and Off-Road Forum
 
Pirate4x4.Com : 4x4 and Off-Road Forum  

Go Back   Pirate4x4.Com : 4x4 and Off-Road Forum > General Tech > Tow Rigs and Trailers
Notices

Reply
 
Share LinkBack Thread Tools Display Modes
Old 03-26-2018, 10:43 AM   #76 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Standard oil/water radiator cooler in the truck. If it's a problem i'll add more to it, whichever adds the most volume. Haven't pulled anything heavy so I have no idea what it'll do temp wise, but that said PO never had issues with the stock setup.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 04-10-2018, 12:13 PM   #77 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Soooo pain full the process of working on this truck lol.

still need the two lines made up, but otherwise it's mostly together. Got the new gauges hooked up, they work great, just small odds and ends (clamp the exhaust, add in the hangers, add a straight length of tube, hook up gear shift & parking brake, toss on front clip and connect the lights) to button up and its done. Also don't like how the throttle linkage feels, gotta play with that some more so it's right.

that said tried to start it Saturday night, no luck. Need someone to help bleed the injector lines while turning it over then it should fire.

This Friday night/Saturday is my running goal.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Old 04-16-2018, 09:07 AM   #78 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Got it running finally:


https://www.facebook.com/cody.ford.5...60234079315282

Took forever to get the fuel system bled, also found out the starter was no good for some reason. The solenoid to engage the gear was moving things to far and it was pressing/dragging against the flywheel, was also drawing way to many amps as a result and melted the battery cable ends. Luckily I knew the starter was questionable and I grabbed a spare from the farm, swapped the nosing and put some new cable ends on the battery cables, and away I went. Starts easy once the air was bled from the system. Only bad thing, is the crank case pressure is a little high for my taste, way better than before, but still a touch high. I'm going to keep an eye out for a NGD head and have it redone and ready to go at some point. I do have a couple known, good ag heads available, just in case.

Need to tie up all the wires/cables/hoses, hook up the ebrake, put the doghouse back on it (had to take the entire thing apart as I had to change a tranny cooler line fitting and install the line itself), put the dash together and mount the new gauges, re-wire the lights and trailer brake, and toss some exhaust hangers on it. Also, the throttle cable/pedal setup is still questionable, way too stiff and bad return to idle, so I'm going to work on that as well. Need to adjust the angle to have a straighter pull, also going to lengthen the throttle arm on the pump to get more pedal travel and less "touchiness" on the pedal.

The 6 in 1 guage works great, as does the tiny tach. Tossed the front clip back on as well as we are getting 6-8" of snow right now lol.
Attached Images
 
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
 
Old 04-16-2018, 09:26 AM   #79 (permalink)
Granite Guru
 
GLTHFJ60's Avatar
 
Join Date: Aug 2009
Member # 140040
Location: Durham, NC
Posts: 947
Nice work!! Bet it was a good feeling getting it running.

Snow blows! Haha
__________________
1987 4BTJ60 - MoonShine - 4BT/NV4500/EcoBox/NP205/D60/14B
2004 F-550 - 6.0/ZF6 - full bulletproof
GLTHFJ60 is offline   Reply With Quote Quick reply to this message
Old 04-16-2018, 09:31 AM   #80 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Big relief to get it running more than anything. Sunk a lot of money into it since November (at least 5k), good to know I didn't just piss it all away lol.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 04-17-2018, 09:30 AM   #81 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
video of the 6 in guage set (sorry its a facebook video):

https://www.facebook.com/cody.ford.5...0239354395282/

First fire video:

https://www.facebook.com/cody.ford.5...0239348915282/
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF

Last edited by mustange70; 04-17-2018 at 09:30 AM.
mustange70 is offline   Reply With Quote Quick reply to this message
Old 04-17-2018, 08:05 PM   #82 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Which one of you added me on shit book? Lol
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 04-21-2018, 10:51 PM   #83 (permalink)
bf
Granite Guru
 
bf's Avatar
 
Join Date: Mar 2009
Member # 131367
Location: UH-UH
Posts: 958
subscribed,

i just bought an s1724 crew as well. they swapped my gas motor for a detroit 4-53t so im looking to upgrade down the road.

that p pump sounds like its going to be fun with that bigger turbo
Attached Images
 
__________________
1994 Explorer build. super-duty on tons, currently in surgery.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by bf; 04-21-2018 at 10:53 PM.
bf is offline   Reply With Quote Quick reply to this message
Old 04-22-2018, 08:44 AM   #84 (permalink)
Registered User
 
Join Date: Dec 2003
Member # 25448
Location: Saskatoon, SK, Canada
Posts: 926
A guy on the dt466 Facebook group just put a 13mm pump oh on his 466 and I think it's going into a Superduty. Should be pretty crazy.
__________________
I should go wheeling
SkZuk is offline   Reply With Quote Quick reply to this message
Old 04-23-2018, 09:49 AM   #85 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
That 13mm p pumped 466 is going in a crew cab travelall, the superduty guy has a DT360 with a 13mm p-pump.

So last few days got the truck back in drivable shape, lights/shifter/ebrake/etc and i took it for its first drive on Saturday. First mile went great, then it went bad. fuel knock/leaking injector to injector cup and yeah. So fixed that re bled the fuel, and away I went the next day to get it home. Fuel knock (more like a deafening hammer) came back, and 20minutes into a slow drive back it lost power and I killed it. Haven't tried to start it since, but I'm at a loss. Had oil pressure, was at 200*f when I shut it off. Still turns over, didn't have any loud/strange noises, etc.

Going to drain some oil and make sure there's nothing fishy, likewise for the fuel filters. Then I'll pull injectors one by one, pull them apart, clean them, make sure everything is sealing in the cups, and also get a boroscope and look down the hole at the pistons and make sure nothing fishy is going on.

If all is good I'll double check the fuel system and make sure its not sucking air somehow, and see if that helps.

Found out I do have to go through the turbo, it is leaking oil out the exhaust, and the turbo flange outlet is also leaking (may have the wrong clamp or flange on the exhaust) exhaust.

On a side note, before shit hit the fan, the turbo/pump combo is really nice. Boost build quick, and with no load on flat ground it'll build up to 30lbs in the short drives I've done, and it does it by like 2k rpm. Lag, etc, are not different then the stock turbo/pump setup. Good combo over all.
Attached Images
 
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF

Last edited by mustange70; 04-23-2018 at 09:51 AM.
mustange70 is offline   Reply With Quote Quick reply to this message
Old 04-23-2018, 10:21 AM   #86 (permalink)
Granite Guru
 
GLTHFJ60's Avatar
 
Join Date: Aug 2009
Member # 140040
Location: Durham, NC
Posts: 947
Bummer
__________________
1987 4BTJ60 - MoonShine - 4BT/NV4500/EcoBox/NP205/D60/14B
2004 F-550 - 6.0/ZF6 - full bulletproof
GLTHFJ60 is offline   Reply With Quote Quick reply to this message
Old 06-19-2018, 05:21 PM   #87 (permalink)
Wheeler
 
Join Date: Jul 2016
Member # 690058
Posts: 179
Any updates on this project? It’s sort of a cliffhanger from the last post...

I hope things turned out okay!
Sask466 is offline   Reply With Quote Quick reply to this message
Old 06-25-2018, 06:53 PM   #88 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Lol, back together and running, somehow fubard a head gasket during reassembly and had to pull it apart again and replace the head gasket. Turbo is questionable, melted piston on the turbine kinda was hard on it, so I'm keeping an eye for a replacement cartridge.

Also built new throttle linkage, works way better, also fixed the kickdown linkage. Currently working on mounting the new seats then ill go for a drive.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 06-26-2018, 07:58 AM   #89 (permalink)
Wheeler
 
Join Date: Aug 2009
Member # 141001
Location: Sanford, NC
Posts: 362
Pics of the throttle linkage? I need to replace mine.

Sent from my LG-H872 using Tapatalk
oscar80 is offline   Reply With Quote Quick reply to this message
Old 06-26-2018, 09:08 AM   #90 (permalink)
Registered User
 
Join Date: Dec 2003
Member # 25448
Location: Saskatoon, SK, Canada
Posts: 926
Quote:
Originally Posted by mustange70 View Post
Lol, back together and running, somehow fubard a head gasket during reassembly and had to pull it apart again and replace the head gasket. Turbo is questionable, melted piston on the turbine kinda was hard on it, so I'm keeping an eye for a replacement cartridge.

Also built new throttle linkage, works way better, also fixed the kickdown linkage. Currently working on mounting the new seats then ill go for a drive.

Nevrenufhp said somewhere that the turbo from an E would be a good upgrade for a C or mechanical NGD. I am thinking doing about that since I have it. In that case I'd have my turbo from my NGD here.
__________________
I should go wheeling
SkZuk is offline   Reply With Quote Quick reply to this message
Old 07-01-2018, 12:34 PM   #91 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
With the 12mm p pump, factory turbo is too small, need next size or two bigger, my turbo is a hair smaller then an hx50. Also with the t4 flange, Id have to change everything again to the smaller flange.

Ill grab a throttle linkage picture later today.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 08-30-2018, 08:18 PM   #92 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF

Last edited by mustange70; 08-30-2018 at 10:43 PM.
mustange70 is offline   Reply With Quote Quick reply to this message
Old 08-30-2018, 10:49 PM   #93 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Work has killed my summer, been picking away at things. Motor is running great, been fighting lift pump regulator issues, and getting something to actually work. Hoping tomorrow to get that straightened. Been fighting leaks randomly, trying to get it as leak free as possible, keep pesky neighbors and the city and DOT off my back. Right now I have a leaky brake line fitting and passenger rear axle seal, replaced a rear caliper, redone a number of engine fittings/hoses, tranny line, Power wise its great, have some valve train adjustments to do, and then i'll play with pump tuning some more.

The paint, ive been wanting to get rid of the multi color for a while, so an air sander and 180grit over everything to knock the loose paint off, rustoleaum cheapy satin black rust paint, acetone & reducer, cheap spray gun and two days of work and what you see is what you get, awesome 20' paint job
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 09-04-2018, 06:49 PM   #94 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Stack material picked up, some 5" square tube, 1/8 wall, was cheaper then exhaust pipe lol. Going to match the cab profile as best I can. Also trying to track down the fender pieces I pulled off.

Interior was also cleaned up, clean as much of therust up as possible, cleaned everything else, painted everything grey, also added in some 1/2 thick rubber matting over the entire floor. Have some carpet underlay rubber that I'll line both sides of the firewall with for noise. Got the seats back in and also finally got 5 new lap belts installed. Pictures will follow.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 09-05-2018, 09:34 PM   #95 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Stack material:



built new mirrors:








Stripped interior for cleaning/paint/matting/seat belts, i'll get a completed one this weekend.



the superduty seats I had already done the brackets prior to the abve:







Spaghetti noodled brake line replaced with a new one.



that's pretty wel brings us up to date.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF

Last edited by mustange70; 09-05-2018 at 09:35 PM.
mustange70 is offline   Reply With Quote Quick reply to this message
Old 09-17-2018, 11:37 PM   #96 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
#stackarack. 5" x 1/8 square tube with some internal baffles at the mid tube, fairly quiet, sounds fantastic.




__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF

Last edited by mustange70; 09-17-2018 at 11:40 PM.
mustange70 is offline   Reply With Quote Quick reply to this message
Old 09-19-2018, 11:29 PM   #97 (permalink)
Wheeler
 
Join Date: Jul 2016
Member # 690058
Posts: 179
Looking good! That flat black suits it. Get those Dayton’s painted up and it will look really good!

I can’t remember if you ended up putting one in... did you install a pyro? I am curious of your EGT’s with a slightly turned up pump and no charge air cooler. On my project I am running a similar setup (466c, S2E turbo, and slightly turned up pump). I haven’t got in on the road yet though.
Sask466 is offline   Reply With Quote Quick reply to this message
Old 09-20-2018, 04:22 AM   #98 (permalink)
Registered User
 
Join Date: Jul 2011
Member # 193950
Posts: 1,864
I would put one more piece of crosstubing at the height of the top of the cab so you can set long stuff on it, but that is just me...

Aaron Z
aczlan is offline   Reply With Quote Quick reply to this message
Old 09-20-2018, 08:04 PM   #99 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Quote:
Originally Posted by aczlan View Post
I would put one more piece of crosstubing at the height of the top of the cab so you can set long stuff on it, but that is just me...

Aaron Z

That was the plan, but ran out of tube, that's 20' pictured.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Old 09-20-2018, 08:07 PM   #100 (permalink)
Registered User
 
Join Date: Jan 2005
Member # 41097
Location: Calgary
Posts: 4,133
Send a message via MSN to mustange70
Quote:
Originally Posted by Sask466 View Post
Looking good! That flat black suits it. Get those Daytonís painted up and it will look really good!

I canít remember if you ended up putting one in... did you install a pyro? I am curious of your EGTís with a slightly turned up pump and no charge air cooler. On my project I am running a similar setup (466c, S2E turbo, and slightly turned up pump). I havenít got in on the road yet though.

Yeah, have a 6 in one gauge with pyro, right at turbo outlet, full throttle non load it'll hit 700-750* that's at 36psi, and I haven't played with the pump nor timing, and I'm running a turbo with double the airflow vs stock at that boost number.
__________________
81' International S1724 DT466 toyhauler w/fun parts
96' Ranger: kings, EMF parts, 800hp SBF
mustange70 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Pirate4x4.Com : 4x4 and Off-Road Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.

** A VERIFICATION EMAIL IS SENT TO THIS ADDRESS TO COMPLETE REGISTRATION!! **

Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0 ©2011, Crawlability, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.