Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5,944 Posts
Discussion Starter #1
hey whats going on. im asking this question for a friend because he doesnt know the deal with his ram. im a toyota guy so i thought id throw this post up here to see if i could help him out. hes got an 01 and all the gauges on the dash keep going out. its happened twice now. hes pluged in the OBD and it reads theres an emissions leak. it got taken in and it was fixed and then if im correct, the same day he got it back the check engine light came on but all the other stuff was fine. i was wondering if anyone else has had problems like this or maybe it might do this on this specific year. he wants this shite fixed. thanks for the help.
 

·
Registered
Joined
·
337 Posts
Here's some info on a self diagnostic test for my '98 Dodge, but it'll probably be the same. If it turns up a code in the LCD (odometer) then post it and I can look it up if you don't have access.

With key in 'off'push in the trip odometer reset button and hold it in. Turn the key to on while holding the button in, but don't start the truck. Hold the button in for approx. 10 seconds....you should see 'CHEC' when it's ready. If there are any failure codes/messages, they will show up in the LCD area. After this the gauge cluster will perform a bunch of tests on the lights and individual gauges. Indicator lights will come on, then the individual gauges will do an actuator test and the needles will peg high then go to two other points then back to a 'rest' position.

These tests will at least show if the gauges are working correctly. Try this test when the gauges are working normally and if no codes pop up, try it again if they stop working again and see if anything comes up.

Hope this helps,
John
 

·
Registered
Joined
·
5,944 Posts
Discussion Starter #3
right on thanks. ill let my friend know and see what happens. ill get back to you.
 
1 - 4 of 4 Posts
Top