Pirate 4x4 banner

1987 Toyota Pickup - 22r - No Spark

2438 Views 4 Replies 4 Participants Last post by  Navek Ydeer ...
Hey guys,

So I am having a crank no spark issue with my 87 pickup with the 22r.

I am going to try to be as detailed as possible.

I determined I had no spark at the plugs OR the ignition coil due to the primary numbers being out of spec. I then purchased a new ignition coil and plugged it in and still nothing. I then decided that it must be the distributor and found a new one for a decent price so I just decided to pull the trigger and purchase it. Threw it in along with a new cap and rotor and still, nothing. I also set the air gap with some feeler gauges.

Next, I naturally assumed it was either a bad ground or the igniter. So I took the grounds off (one near the battery running to the fender wall and one going to the engine and cleaned them up and took the paint off for a clean connection.

Next I assumed it was the igniter as everything else was absolutely fine (I also changed the plugs and wires as they were cheap)

I went to go and find an igniter and the cheapest price I got quoted was 750$ and 6 weeks out.

Next, I read about people doing the GM HEI swap and saw how cheap it was so I decided to go for that.

It was simple enough, I mounted it down and ran a ground wire from the mounting hole to the a good ground spot.

Then I ran the distributor wires (red and white) to the "G" and "W" terminals.

I then used a test light and determined from the factory plug that the igniter/coil plugs into, that it is only getting 12v switched from one side so I threw a male spade lug in that side and ran two wires off of it, one to the "B" terminal and one to the "+" on the ignition coil. Then from the "C" terminal I ran a ground wire to the "-" on the ignition coil.

This is where I am stuck, I am getting 12v power to the "+" on the ignition coil and the "b" terminal on the ignition module which I believe is correct. BUT, I am also getting 12v to the "-" on the ignition coil AND the "C" terminal on the ignition module. Which I believe shouldn't be the case?

If anyone has absolutely any idea on where to start from here on or what I could check to see what could be an issue it would be greatly appreciated. Could this be anything related to the ignition switch? I am under the impression it wouldn't even crank with a bad ignition switch? Could this cause no spark?

Thank you for reading
See less See more
1 - 5 of 5 Posts
bump - anyone have any ideas?
Any gauge or charge light? I've had a bad alternator do something like this on my 22R. youve probably tried this but I didnt see it mentioned, best of luck!
Wow sounds like a nightmare...if your getting 12 volts it should be good... find someone with the same truck n look at their wires
..if it was a fusible link you would have no power at all.. anywhere...if it is under 12 volt I would check your engine 10 amp fuse down by your left foot , fuse box ... if that is out your alternator won't charge... Best of luck... leave a post to update . Maybe someone with the knowledge will come up... Best of luck ..
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.