Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

I have been browsing the forums for a while and have been working on a problem in my head for a while and can't think of any problems so I am turning to all of you for help. I have a 1996 Trooper with the 3.2l v6, when I drive it for, lets say about an hour (only on the freeway) it starts to struggle before it ends up having me flooring it to keep it going 60, the only times I have noticed it is driving from Phoenix (AZ) to Payson or Flagstaff, so it is going uphill and it is definitely better going downhill but when I am driving uphill, its not that steep and it still slows me down rediculously, and ruins my fuel economy while its at it. Heres some things I have done


Replaced muffler (Old one was rusty)
Had shop replace transmission filter and fluid
replaced oil filer
Replaced o2 sensor
replaced IAC
replaced timing belt
replaced waterpump
replaced alternator
replaced A/C Compressor
replaced battery
Checked backpressure (at intake manifold) and all looked good
Just passed emissions so I think the cat is good

I know some things on that list aren't related to my problem, I just felt like I should say it all in case something is weird that I don't know about, I am out of ideas. One other thing that happens (that I think (MIGHT) be related, but I'm really not sure, is that whenever it's time to fill up on gas, I open the filler cap and it sounds like my gas tank was pressurized, without fail, every time, I cant tell if its pulling air in but I think its pushing it out, I think the cap is good however because they check it with emissions. I would just like to have this problem solved because so far, its really my biggest issue with the Isuzu overall.

Thanks for the help
 

·
Wheeler
Joined
·
2,780 Posts
I had an isuzu that did exactly what you are describing for a while, then one day the rods and crankshaft became one piece .


Never had another, sold it just like that .



Those thing were junk from day one, sorry not sorry .
 

·
Registered
Joined
·
762 Posts
any other symptoms? Could be losing fuel pressure, a little drop in pressure makes a pretty large drop in power but might not be enough to trip a lean condition light
 

·
Registered
Joined
·
5,785 Posts
My guess would be the cat heating up.

Take it for a drive, get it to do it again and then check cat while hot.
 
1 - 4 of 4 Posts
Top