Pirate 4x4 banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,147 Posts
Discussion Starter #1
I finally got my eb out for the first time after a delayed year long rebuild.
pics
I know its mud. Thats all I had to work with, unfortunatly.:(

Well I am happy with my suspension it turned out very balanced. Although, since I had all my shocks mounted upside down I had no dampening at all on compression, it still drove well. Side hilling kicked ass. Performance on the rocks was pretty good except for having to much wheelspeed in low-low.

Changes are cutting the rockers off, intigrating tube rockers as tie in for cage to frame, beefier front suspension arms and a klune.
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #5
thanks:beer:

Springs are some old 3.5wh rockcrawl coils.
I fabed the radius arms and they should be atleast 12" longer I think. They're 45".
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #7
rc60- 5.13's detroit
14ff- 5.13's detroit- 3/4 chevy disks
435-205(klune hopefully the begining of the season)
:( 302
150's shackle flipped moved axle back 1"
custom 3-link -3.5 wh coils bent&twisted coil pivots axles 3-4" forward.
jess's high angle shafts 1350cv's to 1410

Lots of fawkin mud :mad:
 

·
Registered
Joined
·
296 Posts
:cool:
Damm fine job Scott, must be nice to get it out of the garage. I like the body cut on the front, a ready for business look. Inspirational, I'm gonna go fire up the sawzall and the mig.
:D
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #10
Thanks glad to be of some insperation towards some cut'n and burn'n.
IronbenderII- guess you gave up on the portal route:( . At least you should see some less down time though.:D

I am wishing to run and beat on this thing all season because I have some cool plans lerking in the back of my head for when the time comes. I'm fawk'n pissed right now though cause my starter went out along with the solinoid. I got a new solinoid and working starter but it still just clicks. Then the optima died and for some reason the wire for the temp gauge starts smoking big time when I turn the ignition on. :confused:
 

·
Registered
Joined
·
1,984 Posts
Without cutting up the frame, I couldn't make the portals work. I'm not ready to commit to that level yet. I just want to get the thing rolling again! I'm getting closer...

Maybe your starter has fried and is putting power to the block? Ahhh, the joys of wheelin a classic!

-Jack
 
1 - 12 of 12 Posts
Top