Pirate 4x4 banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10,444 Posts
Discussion Starter #1
It don't work..
period. I can't get the cruise to turn on at all.


2000 F350 CC long bed.

Anyone that had this problem what should I look for in diagnosing the issue??

Long roadtrips without CC sucks..
 

·
Registered
Joined
·
3,712 Posts
there is an electrical connector on the front of your master cylinder pull it off and short the connector see if it fixes the problem. If it does replace the switch.

The switch is a safety in the cruise system to turn it off w/ brake pressure. The switches have a rubber diaphragm in them that has been known to leak there are recalls on some ford vehicles to replace this switch due to fire b/c there is always power to this circuit.
 

·
Registered
Joined
·
10,444 Posts
Discussion Starter #3
okay, next question, do I have to rebleed the brakes if I replace the switch?
 

·
Registered
Joined
·
10,444 Posts
Discussion Starter #4
unplugged the plug
tried cruise, no go
jumped the two wires together.

Tried Cruise, no go.

:(
 

·
Registered
Joined
·
553 Posts
Any fuses blown?

Does the horn work? The connection in the steering wheel called the clockspring can go bad. There is one for the cruse, one for the horn, and one for the airbag. If one goes, usually the others do, but not always. There is a diagnostic ford can do to determine if the connection is good.

Adrianspeeder
 

·
Premium Member
Joined
·
4,527 Posts
auto or 6 speed? it could be your clutch pedal switch.
 

·
Registered
Joined
·
81 Posts
TR said:
auto or 6 speed? it could be your clutch pedal switch.
That would be my guess. There are a couple switches on the clutch and brake pedals. It's easy to bump them with your feet and get them out of adjustment.
 
1 - 8 of 8 Posts
Top