Pirate 4x4 banner

1 - 7 of 7 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter #1
On a 84 22r it act's like it has a dead battery, it cranks very slow but the battery is brand new and the starter it as well. Anyone have any idea's?????
 

·
Registered
Joined
·
726 Posts
I spent $280.00 to figure this 1 out alongggggg time ago.








Take starter BACK out and have bubba Test it to see how many AMPS it neads to work , I had a good looking hi reduchsion and it was a PITA. we tested it and it was like 495 amps to turn it over.



Yep itll take alot i'am betting = bad rebuid = KRAGENS/CHUCKS ect ect


And replace the Negative BATT-wire too.
and run onother too the engine
and to the body too.

NAPA COST MORE BUT BETTER STUFF TOO.

REIBES ISNT NAPA 100% OF THE TIME ,F.Y.I.

TELL us what fixed it,
 

·
Registered
Joined
·
1,706 Posts
timing could be off too, this will cause it to start sluggishly.
 

·
Premium Member
Joined
·
3,149 Posts
GROUND GROUND GROUND!!!!!!!!!!
 

·
Registered
Joined
·
333 Posts
Discussion Starter #6
I fixed it!!!! You guys we're all right, In my haste to get everything done I forgot to hookup the ground in the alternator wiring cluster, and the timing was off also. Its amazing how easy it is to space off somthing so simple when you've been in the shop for three days straight. Here is to ya guys!!!!!!!!!! THANKS:beer: :beer: :beer: :beer:
 

·
Registered
Joined
·
726 Posts
AWSOME


I GAURANTEE YOU WILL NOT EVER DO THAT AGAIN,






SOBER at least.:D
 
1 - 7 of 7 Posts
Top