Pirate 4x4 banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
hey i searched and didnt find anything like mine does, only in the morning, it takes like 15 to 30 seconds of cranking to get it to start...then it starts but it runs rough for a couple seconds than cleans out...but it only does it in the morning than its fine all day...any help would be great...thanks
 

·
Registered
Joined
·
20 Posts
Cold Start Injector? Have you verified there is pressure there? Have you tried jumping the fuel pump connector? Is it only in the morning or is it after it has been sitting for say 8 hrs?
I had a very similar problem as you describe, and what it was for me was a small coolant leak coming from under the throtle body. I replaced the leaky hose and now it starts like a champ every time.
Hope this helps,
Tye
 

·
Registered
Joined
·
2,429 Posts
1st check for engine codes. i agree try jumping the fuel pump diagnostic plug, and see if that helps. check the cold start injector per service manual
 

·
Registered
Joined
·
1,531 Posts
I had the same problem in my p/u. I never totaly solved the problem though but here are the things that I tried:

Cold start injecter x3
thermo time switch x2
temp switch x2
AFM
Re timed the engine
discovered a ruptured rubber fuel line in the tank
coil/ igniter
checked for air leaks
vacuum leaks
etc, etc...
 

·
Registered
Joined
·
166 Posts
i had the same problem with mine starting in the morning, had toyota check it out and they said the cold start injector and sensor. changed both last week and it's been starting up fine since. i'd check other things first though as the sensor and injector weren't cheap. i paid like $250 for both. took less than an hour to change though.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
its only in the morning, it can sit 8 hours at work and still starts fine....i know where the cold start injector is but i have no clue where the sensor is...thanks for the help...justin
 

·
Registered
Joined
·
1,531 Posts
13lettershitspreader said:
its only in the morning, it can sit 8 hours at work and still starts fine....i know where the cold start injector is but i have no clue where the sensor is...thanks for the help...justin

Which one????
 
1 - 8 of 8 Posts
Top