Pirate 4x4 banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3,168 Posts
Discussion Starter · #1 · (Edited)
I got a 87
I drive this turd into a step area behind house
it requires a bump and a little gas to do this obsticle
every time i do this the truck dies, like you turn key off, then it will not start
winch it onto flat ground... then after some cranking it will start
it is getting fire at the plugs when it wont start
fuel pump is getting juice when it won't start
took sender out of cell
everything appears to be as it should
no debris in line between cell and filter
going to change fuel filter tomorrow
check engine light is not on..

(edit...can't get the thing to die when on the ramp, seems like
it requires a little roughness and offcamber to achive this)

am looking for idea's
 

·
Registered
Joined
·
9,442 Posts
I had a similar thing happen to me once.. real bummer being that it would not do it all the time.. ended up being a wire that had rubbed through under the efi plenum against the fuel rail that feed the injecters.. it was a pain to get to.. check that harness out
 

·
Registered
Joined
·
2,143 Posts
Need to tell us if it's fuel or spark - as mentioned above, it's probably electrical.. Determining fuel or spark will help a lot.
 

·
Registered
Joined
·
1,407 Posts
This may sound like a stupid question but do you have enough fuel in the tank?

Otherwise its probably a short . . . I've got one like that that I've been trying to chase down for months.

Chass
ct
 

·
Registered
Joined
·
12,645 Posts
if it is happening when you bump it, check your motor mounts, and the intake tube going from the afm to throttle body. and also check the wire that runs from the harness at the intake to the coil. it runs over the exhaust, heats up and corrodes.
 

·
Registered
Joined
·
3,168 Posts
Discussion Starter · #6 ·
plenty of fuel
changed fuel line between sender
and the pump also changed the fuel filter
took it on a 2 hour ride tonite thrashed it pretty
hard with out any issue's other than a heater hose blowed
....hope it is fixed
also for those that cares.....the stock fuel lines are long
enuf on a RE motor to let you relocate your fuel filter to the inside of
your ford shock tower
 

·
Registered
Joined
·
1,967 Posts
Does the fuel cell have any baffles. Factory tank has baffles around the fuel pickup.
 

·
Registered
Joined
·
3,168 Posts
Discussion Starter · #13 ·
yea I welded a box/baffle in the bottom of the cell
long ago....worked and still works great
went ridin over the weekend and it worked well
Wish i could narrow the problem down, is one of three
things, for search reasons...........
cleaned ground by fuse box
new fuel hose from pickup to sender in tank
fuel filter
 
1 - 13 of 13 Posts
Top