Pirate 4x4 banner
1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
My yota will not start. It will crank all day, but wont turn over. I've done lots and lots of searching but found nothing like my problem. It had a low speed flop (onto its roof) while the p/o was doing dognuts in a big muddy lot, anyways it hasnt ran since. So far I know the fuel pump has power/ works, the afm works, coil/ign are good, distributor is good. There is fuel in the system, it has spark on all cyls. Cold start injector has current to it, but wont spray. The engine does have fuel pressure tho, at least up to the fuel rail side of the fuel filter where I checked. If I crank it and spray starter fluid in the cold start injector hole it fires right up but as soon as I stop spraying it slowly dies out, like it runs out of combustables. I was able to control the idle today by spraying in intermintent bursts of starter fluid, so I know it can run. Bottom line- I have spark, I have fuel pressure and current at all injectors, but no go.

End rant..
Could it be that when the truck was rolled oil gunked up the injectors so bad that they are worthless now? When I got the truck I could tell oil ran out the intake manifold and down the stock intake tube. The air filter had oil on it as well.

Thanks for the replys!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
Lord Orange said:
check engine light?

I have power going to the check engine light from the ecu, but the light must be out in the dash.

Thanks for all the responses, I have already tested my solenoid resistor and it had 2-3 ohms like the manual said it should.
 
1 - 2 of 2 Posts
Top