Pirate 4x4 banner
1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My engine had thirty thousand miles on a rebuild when a timing chain guide disentigrated. The engine was running well. I tore the engine down, used engnbldr's kit, put things back together. This took place during a body swap (both vehicles 85 4runner) and over the course of several months. Now when I try to start it it cranks well and will start, run for a couple seconds then die. I think it is starting off the cold start injector, but the primary injectors are not opening up. I have tested the following, anything else I'm missing? I'm beggining to get frustrated.

Fuel
Cracked the fuel line to cold start injector, fuel leaks.
Pump runs using 4crawler method
Pump runs without jumper when flapper in AFM is moved
Circuit opening relay test good
Swapped in second circuit opening relay that tests good
Fuel cooming from return line while cranking
Solenoid resistor tests good
Swapped in second solenoid resistor that tests good
Resistance between batt - and solenoid resistor 3 ohms
Injector ground attached at manifold/plenum junction 1.5 ohms to batt -
Cold start injector sprays good pattern
Main injectors were sent out for cleaning, flowing etc.
Main injectors do not spray when fuel rail removed, injectors in rail, cranking

Spark
New plugs(NGK gapped .030), cap(NAPA), rotor(NAPA), wires(dealer)
Engine runs for a few seconds so there is some spark
Swapped in second coil and igniter
Resistance between strap around coil and batt - 4.5 ohms
Second distributor tried

Timing
Crank at mark, shiny links on dots, rotor pointing to 1
Again, it runs well for those couple seconds, so I don't think timing is an issue


TPS adjusted per FSM
TPS plug removed bottom two connections jumpered
Second TPS plugged into harness, not attached to TB
Tried second ECU
Intake tubing intact and secured
All new vacuum lines tripple checked for correct routing
Good multiple grounds body to engine
Second ignition switch tried
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
4Crawlr
I have battery voltage at terminal 10 and 20. I Checked out those links and decided to tear the harness apart anyway. I found the butt splice for the ground wires to be in marginal condition so I replaced it with wire and solder. I also replaced a small section of one of the wires that goes to the igniter. Afterwards, no change.

Lord Orange
The harness tests good from the resistor to the injectors to the computer. Also from the igniter plug across the top of the engine to the computer.

Jmsdad
I'm pretty sure you are correct about the injectors not opening. Every once in a while I get kinda discouraged with the thing so I'll start it on starter fluid and see how long I can keep it running. I'm up to about 20 seconds. Unfortunately that is a rather unsuitable fix for my dd. The injectors were bubble wrapped to and from Cruzin Performance for service. I have heard of some other people not having good results with them. The injectors are all about 2.5 ohms. I'm working on getting another set to try.

Commwizz
I tried two different main relays. I tried using a jumper between as you suggested. If the check engine light is coming on with the check jumper installed doesn't that confirm the relay is ok? I get battery voltage between +B and E1 also between Batt and E1

WR250
How do you hook up the resistor incorrectly? On mine there is a one pron plug and a two pron plug.


Anybody have other ideas? This is starting to get old. On thing I noticed and didn't understand was between the white and blue/yellow wires in the injector connector I was getting 3ohms. Doesn't seem like there should be continuity there with the ignition off.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #10 ·
I tried jumpering terminals 10 and 20 to ground(simultaneously, ignition on) and the injectors all clicked. So I think that rules out any problems between the ignition switch, the injector resistor and the wiring to the computer. Any other ideas?

On a related note, the fuel pump jumper has ceased to activate the fuel pump. It will make the check engine light operate like it is supposed to and the fuel pump still turns on when you move the flapper in the MAF. weird huh.
 
1 - 3 of 3 Posts
Top