Pirate 4x4 banner

1 - 10 of 10 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter #1
87 efi 22re

When you first hit the key it fires then just turns over and over. Let it sit for a few minutes then fires then just turns over. You can try this all day and that is all it will do. I shot a little starter fluid in the intake and it starts for a about 3 seconds and then just dies. Anybody have a clue?

I replaced the fuel pump- maybe it isnt putting out enough pressure? fuel line partially blocked? Somebody help me start this thing. There is not a single mechanic around here that will touch this thing.
 

·
Registered
Joined
·
5,809 Posts
Sounds like your injectors may not be firing. Get a fuel pressure gauge and check your fuel rail pressure when your pump's going. If that's good then see if your injectors are powering.
 

·
Registered
Joined
·
609 Posts
is your air flow meter sticking? Reach into the air box and feel the air flap to make sure that it opens up smoothly and all the way thruogh it's 90 degree rotation. The fuel pump should start to run as soon as the air flap opens up. If it dosen't then it sould be the fuelpump relay ( you should hear a click inside the cab on the pass side when the air flow opens) Do you have any codes?
 

·
Registered
Joined
·
342 Posts
denver d said:
is your air flow meter sticking? Reach into the air box and feel the air flap to make sure that it opens up smoothly and all the way thruogh it's 90 degree rotation. The fuel pump should start to run as soon as the air flap opens up. If it dosen't then it sould be the fuelpump relay ( you should hear a click inside the cab on the pass side when the air flow opens) Do you have any codes?

damn im going through this right now, i could hear the clicking, but it feels like i have no fuel gettting to the motor, i have a new fuel pump ready to install, so the clicking i take it means the air flow is opening and is fine, and isnt getting any fuel, mine would run, then quit, wait a few hours, idle fine , then die out, so i guessed fuel pump, am i correct,,,,,,,,,,,later
 

·
Registered
Joined
·
520 Posts
Discussion Starter #7
northpole85 said:



damn im going through this right now, i could hear the clicking, but it feels like i have no fuel gettting to the motor, i have a new fuel pump ready to install, so the clicking i take it means the air flow is opening and is fine, and isnt getting any fuel, mine would run, then quit, wait a few hours, idle fine , then die out, so i guessed fuel pump, am i correct,,,,,,,,,,,later
At least yours will idle for a while. Mine wont even start. Let me know if you find something.
 

·
Registered
Joined
·
126 Posts
When I put my new feul pump on I had to unhook the feul line and turn the key on without turning the engine over till it started pumping feul out then hook it back up. It wouldn't prime with the air in the line.
 

·
Registered
Joined
·
520 Posts
Discussion Starter #9
That is a good observation although Im getting fuel to the rail. I can undo the line at the rail and all kinds of gas sprays out??? Im willing to try it though. Maybe it just has air in the lines....
 
1 - 10 of 10 Posts
Top