Pirate 4x4 banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello I have a 1995 Chevy 2500 that had a 350 tbi. I’m put a1995 454 tbi in the truck but can’t get it to start. I get spark and have fuel. Can someone please help me on what I need to do. Will I have to do anything to the ECM? Any advice wil be greatly appreciated
 

·
Registered
1979 F150 351w np435 on 37s. 1995 YJ 4Banger with 5speed on 31s. 2000 XJ 4.0 auto on 31s.
Joined
·
361 Posts
Are you using the 350 throttle body, or the 454 throttle body? same with the ecm, the 350 or the 454? The tbi also is hard to start when the coolant temp is unplugged, I'd double check that too. Are you sure the timing is right? could be 180 degrees off. Kinda hard to help without many details though.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Sorry guys. So I barely got to hear the 454 run. It was in a 95 motor home and I bought the motor to put in the 1995 Chevy 2500 truck I also just got. I’m using the 350 wiring harness although I had to change a couple connections. Idk much about mechanical work and i still have to hook my vacuum lines up but can’t find out how they go. About the timing. The way I was told to do it is unplug the wire that under my glove compartment and bump the motor until you feel air coming out of number 1 plug hole. Also I was just checking plugs and number1 plug was dry but number 4 was wet. I didn’t check anymore. Will the 350 ecm work on the 454?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Sorry guys. So I barely got to hear the 454 run. It was in a 95 motor home and I bought the motor to put in the 1995 Chevy 2500 truck I also just got. I’m using the 350 wiring harness although I had to change a couple connections. Idk much about mechanical work and i still have to hook my vacuum lines up but can’t find out how they go. About the timing. The way I was told to do it is unplug the wire that under my glove compartment and bump the motor until you feel air coming out of number 1 plug hole. Also I was just checking plugs and number1 plug was dry but number 4 was wet. I didn’t check anymore. Will the 350 ecm work on the 454? Also I’m not using the 350 tbi intake.
 

·
Registered
Joined
·
8 Posts
The 350 PCM should work, it should be a PROM chip style PCM. You'll need to get a PROM new chip made though. Contact tbichips.com and they should be able to help you with that.
 
1 - 7 of 7 Posts
Top