Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
151 Posts
Discussion Starter #1
I was driving the truck the other day and truck was running fine and noticed the tach needle jumping around like crazy throughout the rpms ... The truck runs fine and doesn't idle rough or anything, just one min it was fine the next its bouncing around. It's not steady.. I have one of them aftermarket sun pro tachs cause the stock one in the guage cluster never worked right. Checked all my connections and nothing came loose and no wires are broken. I checked the coil and its good. Checked the ignitor or icm and its good.. any ideas as to what's wrong?
 

·
Registered
Joined
·
151 Posts
Discussion Starter #4
I checked that thread out. Has lots of info. My stock cluster never had a tach so I got the one that had it in it and it kind of worked.. only showed 1500 rpms when I was doin like 4500.. I never hooked up a wire from the - side of my coil to the cluster tach I just hooked the sun pro wire up to the - side and always worked. Up till a few days ago when I was driving it just happend in a split second. One min it was fine the next not so fine. All over the place. I checked the coil it was fine. The igniter seems fine. I swapped coils for the hell of it and no dice. I checked grounds all good. Pretty much traced all the wires and found nothing. There are a few resistors or capacitators on either side of the coil.. one the wire looks all fraded so tomorrow il:shaking:l fox that and the other looks fine. Other than that. I'm lost. I'll post pics tomorrow
 
1 - 4 of 4 Posts
Top