Pirate 4x4 banner

1 - 14 of 14 Posts

·
Registered
Joined
·
27,625 Posts
Factory case? I would think the case should have broke and spit the pinion support out, before the caps
 

·
Registered
Joined
·
7,777 Posts
What's the story behind the carnage?.....tire size, motor, situation, terrain, etc.?
 

·
Registered
Joined
·
536 Posts
Apparently its quite common with the ford gray iron cases. I did the same thing to one a couple of years ago before upgrading to the Nodular race case from Currie.
 

·
Registered
Joined
·
5,465 Posts
I broke many main caps as well. they seem weak in stock form when abused alot. a nodular case will solve that problem.
 

·
Registered
Joined
·
430 Posts
I broke 4 sets in 2 years, it was always the caps, with a 351,435, 203/205 5.13's and 38"s
 

·
Registered
Joined
·
731 Posts
Wow... all looking around on the net I have never seen that before. I have a True Hi9, I hope it doesnt do that. 35 spline and ARB would be shot Im sure.
 

·
Registered
Joined
·
1,149 Posts
i did the same thing on my old tj ,1978 ford 9" rear 4.10 gears / arb / 37" mtr's / auto / 4.0L bored and stroked to 4.6L. gave it hell climbing the double whammy in moab ( made it too !!), drove up the trail 100 yards climbed small ledge and pow!!! both caps broke:mad3:
 

·
Premium Member
Joined
·
11,120 Posts
I'd guess mine would have ended up the same way if I hadn't stopped right away.







In a '91 Bronco, tired 302, Mazda 5-speed, 3.50 gears, 35's. Moving snow.
 

·
Registered
Joined
·
2,868 Posts
no probs so far on mine and it's still the stock case. has a full spool, 4.88s, 4.3 in a 5200# rig, 37s.......

I beat the living hell out of it 2 weeks ago at the Superlift park and it held up great. the yukons up front did a great as well. too bad I grenaded a hub :grinpimp:

hope ya get it fixed and back on the trail soon

I did have one issue with mine though. I had a mini-spool in it for a while and I was hopping it pretty hard. I heard a loud bang and it felt like it came from the rear. I thought I trashed a pinion gear. it ended up being the pin for the mini was split into 3 pieces. everything else held up.

tweaked a stock shaft as well


 

·
Registered
Joined
·
3,307 Posts
i broke mine the same way, except mine was because i broke a shaft. the splines exlpoded, and from there on out.... :nuke:

i did mine with a 6 Cylinder. :flipoff2:

mine was a 31 spline factory case. now i have a Strange nod. 3rd member and 35 splines... no problems now... (ive got 39.5s on it now... i had 37s on it then...)
 
1 - 14 of 14 Posts
Top