Pirate 4x4 banner

90 YJ charging system question

500 Views 3 Replies 3 Participants Last post by  Tex1978
OK, here it goes. I have noticed that when I crank my Jeep the last couple of days that it seems to spin a little slowly. Today I drove it around for awhile and stopped and when I tried to crank it back up it just spinned over slowly then nothing. The ammeter was at about 10 volts. It has a pretty new battery in it so I don't think that is it, maybe the alternator? I let it sit and tried to crank it later and just got the solenoid click. I then got some jumper cables and hooked it up and it would never get it to spin, just click. I got some friends to help me push start it no problem and then the ammeter showed about 14 volts while it was running. I just tried to crank it again and it just clicked. WTF?
1 - 1 of 4 Posts
It could be the modual. I had the same problem with my YJ. It would like sit in the garage for less than a day, and then I would go to start it and it wouldn't start and I would end up flooding the engine. So I would have to push it out of the garage and jump it then it would run fine. It did this off and on for about 3 months. Then one day I was driving it and I was sitting at a stop light and it just died, so I waiting like 30 min. for one of my friends to bring me gas (thought I ran out of gas because gas gauge doesn't work) when the gas got there I put in way less than a quarter of the little 5 gal. gas tank and it started. I drove it to the gas station and it didn't even take $3 worth of gas. This happened just after I had gotten a new fuel pump and fuel filter put in. So I had my neighbor check the fuel filter and pump to make sure that it was installed right and that it worked good (and it did). So I had the usual problems with it not starting a couple of times in the next 4 months, even took it to a shop to have them look into why it wasn't startin some times, I also went and got a new battery. Then a month after I got the new battery I was driving down the road at 50 MPH in the left hand lane, and it just goes dead and I get it over to the right shoulder, and sit and wait for like an hour and it still wouldn't start. So I had it towed to the shop I use and they put a new modual in it and I haven't had problems with it since.
See less See more
1 - 1 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.