Pirate 4x4 banner

1 - 14 of 14 Posts

·
Registered
Joined
·
456 Posts
Discussion Starter #1
im am about to drive to ky from dallas in a friends 95 1ton with some probs. he says not to worry bout it, but thats a long way from home.

heres what its doin...when u go out to start it, it wont start till u give it gas, and will die if u dont hold the gas dwn. once it is warm it stays runnin, but has a rough idle at 500 rpm's.

any advice will b appreciated, thx.
 

·
Registered
Joined
·
4,738 Posts
and what have you done to try and fix this, or what has HE done?

The 7100 pumps don't go bad very often... fuel filter?
 

·
Registered
Joined
·
456 Posts
Discussion Starter #3
he hasnt done anything yet, his attitude is its been doin it fro ever, so dont worry. i havent done anything, i have never owed a deisil...i will change the fuel filter though...thx

anything eles is apprecitated.
 

·
Premium Member
Joined
·
25,817 Posts

·
Registered
Joined
·
456 Posts
Discussion Starter #5
matts-i looked at that site, but dont have a c-note for a couple of searches for a buddies truck im borrowin...thx for the help, gonna read them now.
 

·
Registered
Joined
·
2,368 Posts
The P7100 trucks tend to loose idle speed over time. Its normal, and easy to fix. They also idle lower when its real hot out, especially after being worked hard.

It is also normal for (many) of these trucks to not start as easy or at all without some throttle input. Mine fires right off if you rest your foot on the throttle, but cranks over a few times w/no throttle.

If the truck has good power and otherwise drives fine, probably nothing to worry about.

Pete
 

·
Registered
Joined
·
456 Posts
Discussion Starter #7
where on the motor is the idle adjustment screw? once i get the jam nut loose, which way do i turn it to idle it up 250 rpms? its idlein around 500rpm's now, should b 750rpm's from what i read on TDR. do u adjust it while its runnin?

how do u check/adjust the timmin?

thx.
 

·
Premium Member
Joined
·
25,817 Posts

Attachments

·
Premium Member
Joined
·
25,817 Posts
tradin1 said:
matts-i printed that out earlier, thx...but where is it exactly?
"Get up on top of the engine and look down at the back of the pump. Helps to hold half throttle or more to expose it. (at idle the linkage sits on the head of the bolt)It is on the rear of the injection pump (throttle control lever). It is a vertical screw. Just follow the throttle linkage back to the control lever."

Sounds like it's on the back the the block.
 

·
Registered
Joined
·
2,368 Posts
Its near the back of the injection pump, kinda low on the pump IIRC. The injection pump is the little I6 looking thing near the top of the motor on the drivers side, with the 6 metal fuel lines coming out of it.

Pete
 

·
Registered
Joined
·
456 Posts
Discussion Starter #12
well i changed the oil, air filter (k&n), and the fuel filter. it drives soooo much better...but still has the hard start.

gonna try to adjust the idle tommor, as i have never done anything w/ a deisil, and didnt know what, or where the injection pump is...i do remember seein the metal lines.

thx for all of the help guys.
 

·
Registered
Joined
·
6,382 Posts
the low idle is common as dirt when they start getting some miles on them. mine wont start with out hiting the pedal a bit. but if you flip down the visor and read the starting instruction it says to give it some fuel on start up anyway. i need to get mine back up in the 750 to 800 range myself, but i am being lazy and putting it off. mike
 

·
Registered
Joined
·
456 Posts
Discussion Starter #14
hey mike, been a while...did ur buddie ever get his m35 ready. he was changin the clutch when i came out to your place a couple of months ago. thx for the advice, i am leavin this afternoon and just wanted to b sure.
 
1 - 14 of 14 Posts
Top