Pirate 4x4 banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3,041 Posts
Discussion Starter #1
The wiring in question is from an 85 4Runner. We have eliminated most items that are not needed, ie wipers and such. We cannot get the alternator to charge the battery. The engine is running off the alternator though. The wiring diagram shows a yellow/white stripe lead that comes from the ECU to the charge lamp, idiot lite. The lead seems to be nonexistent from my ECU.
I was told that the alternator needs a charge lite to activate the circuit. So we wired in a small LED lite in series with the ignition fuse and charge fuse with the diode between the two, as per wiring diagram. We are still missing one wire for the circuit. How many charge type leads are from the computer? And what colors? Or better yet, how the hell do we get the alternator to charge the battery? :confused:
 

·
Registered
Joined
·
3,491 Posts
Jack, run both white wires to battery +. Run the yellow wire to an idiot light, from the idiot light to ignition+. Run the red wire to ignition +. Screw the rest. It will charge. Thats how mine is wired.

EDIT: the LED will not work. It needs a regular bulb.
 

·
Registered
Joined
·
3,041 Posts
Discussion Starter #4
zags said:
EDIT: the LED will not work. It needs a regular bulb.
All better now. Thanks man.
 

·
Registered
Joined
·
4,104 Posts
i had the same problem with my 99 vortec 350. when i first wired it i did not put a charge light in the exciter wire and it would not charge. i didn't know it needed to be in there. after alot of cussing, alt swapping, and stealing the alt from my wifes tahoe, i decided to add a light since that is all that was different according to the schematic. once the light was there no more worries. i would suggest that you keep a spare bulb in your rig. while i have not had one blow it would be bad if it did.
 

·
Registered
Joined
·
12,646 Posts
you should be able to run a wire straight off the post of the alternator to the battery positive. if still same problem, then the power is not making it from the fuse block area around to the positive post of the battery. the power wire (unfortunatly)runs from the alternator, into the cab and splits off to the fuse block, then past the heater boxes and out the other side of the firewall to the battery. why they run such a high amp wire through the dash is just stupid.
 
1 - 6 of 6 Posts
Top