Pirate 4x4 banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello,

I have a 91 dodge ram 5 speed 4x4.

recently I started hearing a clicking noise coming from below the cab. the noise is only under load ( light or heavy ) and stops with the clutch pushed in. Only does it at road speeds ( anywhere above 15 ) I almost 100% know it is nothing to do with the engine.

I checked u joints found one that was really bad. Replaced it and still has the noise.

went crazy all day trying everything to fix it.

found two things which you guys here might be able to clear up for me,

1. Oil seal on the back of a NP205 transfer case seeps oil. also has about an 1/8th inch of play or so.

2. Slip joint on drive shaft has a little play but It doesn't seem that abnormal.


I am really confused about this noise. It does not sound healthy.

My thoughts are something with the transfer case. I tried putting it in 4lo with hubs unlocked and it does it, just slower. It is not some sort of linkage issue because that is all tight.

let me know what you guys think. I figured I could post here cause the Np205 is a very popular case and you guys might have an idea of what is going on.

Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hello,

sorry for the misunderstanding,

maybe the forum should be labeled a little better than it is I assumed it was anything dodge goes here.

feel free to delete my thread I will "go elsewhere"

,Kody
 

·
Banned
Joined
·
3,384 Posts
your getrag probably needs new bearings
 

·
Premium Member
Joined
·
1,308 Posts
maybe the forum should be labeled a little better than it is I assumed it was anything dodge goes here.
Maybe you should have read the thread titled
ATTENTION: Read this thread BEFORE you post!!!

Duane
 
1 - 6 of 6 Posts
Top