Pirate 4x4 banner

1 - 4 of 4 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter · #1 ·
85 toyota with stock carb. I had a weber carb and offy manifold on and swapped it back for the stock carb. Since the stock carb has been on it will never start cold with out spraying something into the carb then it will fire right up. I checked to see if it is getting fuel and I can see it squirt in,choke seems to open and close when its supposed to. I never had this problem before the swap. Does any one know of something that can be easily checked? Any help would be appreciated it get old having to prime it to move it in and out of the garage. <IMG SRC="smilies/rolleyes.gif" border="0">
 

·
Registered
Joined
·
1,024 Posts
Are you sure the choke is working? Before you even put the key in the ignition, under your hood, quickly hit the throttle (i.e. pull it like you were giving it gas)and see if your choke is closing. This will and should let you know if your choke is engaging.
 

·
Registered
Joined
·
3,010 Posts
i agree with bertha.

also check to see if the butterfly valves are sticking. my frieds old pos used to do that. all the carb cleaner and other crap he put into it wouldn't help it worth a crap.
finally had to have it rebuilt. <IMG SRC="smilies/eyemouth.gif" border="0">
 

·
Registered
Joined
·
203 Posts
Discussion Starter · #4 ·
I will check again tomorrow to see if the choke works. Then maybe I will try some carb cleaner or go for a rebuild. Does any one know how much a kit is to rebuild it and if it fairly simple. I have rebuilt many carbs from american vehicles but no Jap ones. Thanks Guys keep it comming.
 
1 - 4 of 4 Posts
Top